summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <mthode@mthode.org>2015-08-27 16:20:34 -0500
committerMatthew Thode <mthode@mthode.org>2015-08-27 16:22:01 -0500
commit56240c05e5e9fcbeabef53b465f01dadda09b4bb (patch)
tree200bdf9eccfefcdc558ca0af4cf2bf14f850fdf1 /dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild
parentdev-lisp/sbcl: bump to version 1.2.14 (diff)
downloadgentoo-56240c05e5e9fcbeabef53b465f01dadda09b4bb.tar.gz
gentoo-56240c05e5e9fcbeabef53b465f01dadda09b4bb.tar.bz2
gentoo-56240c05e5e9fcbeabef53b465f01dadda09b4bb.zip
herd/openstack: Split out libs from dev-python/PyECLib
gentoo-bug: 558884 gentoo-bug: 558886
Diffstat (limited to 'dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild')
-rw-r--r--dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild b/dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild
new file mode 100644
index 000000000000..12215bf8e618
--- /dev/null
+++ b/dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils multilib
+
+DESCRIPTION="Messaging API for RPC and notifications over a number of different messaging transports"
+HOMEPAGE="https://pypi.python.org/pypi/PyECLib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-libs/jerasure"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="dev-libs/liberasurecode
+ ${CDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/PyECLib-usr-local2.patch"
+)