summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-04 09:39:11 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-04 09:39:52 -0500
commit985674aa671567135d601e5e3ea82800db1fa46d (patch)
tree9996dd7d42b66d5244e743c39d414fdbc19fa7d3 /dev-python/PyECLib/PyECLib-1.6.0.ebuild
parentapp-crypt/certbot-nginx: 0.33.0 bump (diff)
downloadgentoo-985674aa671567135d601e5e3ea82800db1fa46d.tar.gz
gentoo-985674aa671567135d601e5e3ea82800db1fa46d.tar.bz2
gentoo-985674aa671567135d601e5e3ea82800db1fa46d.zip
dev-python/PyECLib: 1.6.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/PyECLib/PyECLib-1.6.0.ebuild')
-rw-r--r--dev-python/PyECLib/PyECLib-1.6.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/PyECLib/PyECLib-1.6.0.ebuild b/dev-python/PyECLib/PyECLib-1.6.0.ebuild
new file mode 100644
index 000000000000..ab29e70bcb74
--- /dev/null
+++ b/dev-python/PyECLib/PyECLib-1.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils multilib
+
+DESCRIPTION="Messaging API for RPC and notifications over different messaging transports"
+HOMEPAGE="https://pypi.org/project/PyECLib/"
+SRC_URI="mirror://pypi/p/pyeclib/pyeclib-${PV}.tar.gz"
+S="${WORKDIR}/pyeclib-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-libs/jerasure"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="dev-libs/liberasurecode
+ ${CDEPEND}"