summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-06-17 16:47:26 -0700
committerZac Medico <zmedico@gentoo.org>2021-06-17 16:54:40 -0700
commit863f873b65cee0845f5ac745b5595fdf9de7ea97 (patch)
tree619a1072133c798c46a6e6558013c0681a4332f8 /dev-python/PyQt-builder
parentnet-irc/unrealircd: drop 5.2.0 (diff)
downloadgentoo-863f873b65cee0845f5ac745b5595fdf9de7ea97.tar.gz
gentoo-863f873b65cee0845f5ac745b5595fdf9de7ea97.tar.bz2
gentoo-863f873b65cee0845f5ac745b5595fdf9de7ea97.zip
dev-python/PyQt-builder: Initial import
Closes: https://bugs.gentoo.org/796005 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/PyQt-builder')
-rw-r--r--dev-python/PyQt-builder/Manifest1
-rw-r--r--dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild22
-rw-r--r--dev-python/PyQt-builder/metadata.xml18
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/PyQt-builder/Manifest b/dev-python/PyQt-builder/Manifest
new file mode 100644
index 000000000000..c04be8f9ec1c
--- /dev/null
+++ b/dev-python/PyQt-builder/Manifest
@@ -0,0 +1 @@
+DIST PyQt-builder-1.10.1.tar.gz 5725429 BLAKE2B e7aaa0a3c1eb8aeea0aa5f2d5d7beda1edc46e90c0a21b608d2dffe205a67170daaa6615253706b5f9856a27d66715692ceffe81b9b45eafd4d608df79741d6f SHA512 2e48c1066bb12c1f50700933b0f489158f29f62a1239b570dc053cb042eca9bd4ee83f66b855b0596cfb6dc2e844434c15563abbb3846bf5960d03441f497b83
diff --git a/dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild b/dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild
new file mode 100644
index 000000000000..c7f4ec9ff355
--- /dev/null
+++ b/dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="The PEP 517 compliant PyQt build system"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt-builder/ https://pypi.org/project/PyQt-builder/ https://www.riverbankcomputing.com/static/Docs/PyQt-builder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+RDEPEND="dev-python/sip[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+}
diff --git a/dev-python/PyQt-builder/metadata.xml b/dev-python/PyQt-builder/metadata.xml
new file mode 100644
index 000000000000..0a0159870724
--- /dev/null
+++ b/dev-python/PyQt-builder/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>phil@riverbankcomputing.com</email>
+ <name>Phil Thompson</name>
+ </maintainer>
+ <changelog>https://www.riverbankcomputing.com/hg/PyQt-builder/file/tip/NEWS</changelog>
+ <doc>https://www.riverbankcomputing.com/static/Docs/PyQt-builder/</doc>
+ <bugs-to>mailto:pyqt@riverbankcomputing.com</bugs-to>
+ <remote-id type="pypi">PyQt-builder</remote-id>
+ </upstream>
+</pkgmetadata>