summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2021-06-02 22:07:37 +0200
committerDavide Pesavento <pesa@gentoo.org>2021-06-02 22:13:00 +0200
commit855845d182eafb7cd34fe4279bd639518ec84f98 (patch)
treefb50ec4e1cd14fa9f8e79683ebd5ed60a572dc37 /dev-python/PyQt5
parentnet-analyzer/wireshark: drop 3.4.3, 3.4.4 (diff)
downloadgentoo-855845d182eafb7cd34fe4279bd639518ec84f98.tar.gz
gentoo-855845d182eafb7cd34fe4279bd639518ec84f98.tar.bz2
gentoo-855845d182eafb7cd34fe4279bd639518ec84f98.zip
dev-python/PyQt5: add USE=speech
Bug: https://bugs.gentoo.org/792861 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python/PyQt5')
-rw-r--r--dev-python/PyQt5/PyQt5-5.15.4-r1.ebuild (renamed from dev-python/PyQt5/PyQt5-5.15.4.ebuild)10
-rw-r--r--dev-python/PyQt5/metadata.xml3
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/PyQt5/PyQt5-5.15.4.ebuild b/dev-python/PyQt5/PyQt5-5.15.4-r1.ebuild
index a09f97319d0b..32d0b3c868ae 100644
--- a/dev-python/PyQt5/PyQt5-5.15.4.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.15.4-r1.ebuild
@@ -21,13 +21,13 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-# TODO: QtNfc, QtRemoteObjects, QtTextToSpeech
+# TODO: QtNfc, QtQuick3D, QtRemoteObjects
IUSE="bluetooth dbus debug declarative designer examples gles2-only gui help location
- multimedia network opengl positioning printsupport sensors serialport sql
- +ssl svg testlib webchannel websockets widgets x11extras xmlpatterns"
+ multimedia network opengl positioning printsupport sensors serialport speech
+ sql +ssl svg testlib webchannel websockets widgets x11extras xmlpatterns"
# The requirements below were extracted from configure.py
-# and from the output of 'grep -r "%Import " "${S}"/sip'
+# and from the output of 'grep -r "%Import " ${S}/sip'
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
bluetooth? ( gui )
@@ -74,6 +74,7 @@ RDEPEND="${PYTHON_DEPS}
printsupport? ( >=dev-qt/qtprintsupport-${QT_PV} )
sensors? ( >=dev-qt/qtsensors-${QT_PV} )
serialport? ( >=dev-qt/qtserialport-${QT_PV} )
+ speech? ( >=dev-qt/qtspeech-${QT_PV} )
sql? ( >=dev-qt/qtsql-${QT_PV} )
svg? ( >=dev-qt/qtsvg-${QT_PV} )
testlib? ( >=dev-qt/qttest-${QT_PV} )
@@ -131,6 +132,7 @@ src_configure() {
$(pyqt_use_enable printsupport QtPrintSupport)
$(pyqt_use_enable sensors)
$(pyqt_use_enable serialport QtSerialPort)
+ $(pyqt_use_enable speech QtTextToSpeech)
$(pyqt_use_enable sql)
$(usex ssl '' '--disable-feature=PyQt_SSL')
$(pyqt_use_enable svg)
diff --git a/dev-python/PyQt5/metadata.xml b/dev-python/PyQt5/metadata.xml
index fc69b98a7a4d..c75a05796139 100644
--- a/dev-python/PyQt5/metadata.xml
+++ b/dev-python/PyQt5/metadata.xml
@@ -8,7 +8,7 @@
<use>
<flag name="bluetooth">Build bindings for the QtBluetooth module</flag>
<flag name="dbus">Build bindings for the QtDBus module</flag>
- <flag name="declarative">Build bindings for the QtQml/QtQuick modules and enable the qmlscene plugin</flag>
+ <flag name="declarative">Build bindings for the QtQml and QtQuick modules and enable the qmlscene plugin</flag>
<flag name="designer">Build bindings for the QtDesigner module and enable the designer plugin</flag>
<flag name="gui">Build bindings for the QtGui module</flag>
<flag name="help">Build bindings for the QtHelp module</flag>
@@ -21,6 +21,7 @@
<flag name="printsupport">Build bindings for the QtPrintSupport module</flag>
<flag name="sensors">Build bindings for the QtSensors module</flag>
<flag name="serialport">Build bindings for the QtSerialPort module</flag>
+ <flag name="speech">Build bindings for the QtTextToSpeech module</flag>
<flag name="sql">Build bindings for the QtSql module</flag>
<flag name="svg">Build bindings for the QtSvg module</flag>
<flag name="testlib">Build bindings for the QtTest module</flag>