summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2019-11-05 07:01:39 +0100
committerDavide Pesavento <pesa@gentoo.org>2019-11-05 07:01:57 +0100
commit45635a3d83085be19f7ac6603233684c853fff21 (patch)
tree048c3d9dec8e1a9534c145e2e5ad6666a23f7e20 /dev-python/PyQtWebEngine/PyQtWebEngine-5.13.2.ebuild
parentdev-python/PyQt5: add 5.13.2 (diff)
downloadgentoo-45635a3d83085be19f7ac6603233684c853fff21.tar.gz
gentoo-45635a3d83085be19f7ac6603233684c853fff21.tar.bz2
gentoo-45635a3d83085be19f7ac6603233684c853fff21.zip
dev-python/PyQtWebEngine: add 5.13.2
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python/PyQtWebEngine/PyQtWebEngine-5.13.2.ebuild')
-rw-r--r--dev-python/PyQtWebEngine/PyQtWebEngine-5.13.2.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/PyQtWebEngine/PyQtWebEngine-5.13.2.ebuild b/dev-python/PyQtWebEngine/PyQtWebEngine-5.13.2.ebuild
new file mode 100644
index 000000000000..9614f515fa23
--- /dev/null
+++ b/dev-python/PyQtWebEngine/PyQtWebEngine-5.13.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit python-r1 qmake-utils
+
+DESCRIPTION="Python bindings for QtWebEngine"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqtwebengine/intro"
+
+MY_P=${PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${PN}/${PV}/${MY_P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/PyQt5-5.13.1[gui,network,printsupport,ssl,webchannel,widgets,${PYTHON_USEDEP}]
+ >=dev-python/PyQt5-sip-4.19.14:=[${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtwebengine:5[widgets]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/sip-4.19.14[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ --qmake="$(qt5_get_bindir)"/qmake
+ $(usex debug '--debug --trace' '')
+ --verbose
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Fix parallel install failure
+ sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets' ${PN}.pro || die
+
+ # Run eqmake to respect toolchain and build flags
+ eqmake5 -recursive ${PN}.pro
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ einstalldocs
+}