summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2020-06-10 20:50:12 +0200
committerDavide Pesavento <pesa@gentoo.org>2020-06-10 20:50:12 +0200
commit3d7d699f3ae03420b65da81dc956f08a97a5ee8f (patch)
tree97e1700fb5683a7ae77a307260a66038073d69a3 /dev-python/PyQtWebEngine
parentdev-python/PyQt5-sip: remove 4.19.19 (diff)
downloadgentoo-3d7d699f3ae03420b65da81dc956f08a97a5ee8f.tar.gz
gentoo-3d7d699f3ae03420b65da81dc956f08a97a5ee8f.tar.bz2
gentoo-3d7d699f3ae03420b65da81dc956f08a97a5ee8f.zip
dev-python/PyQtWebEngine: remove 5.13.2
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python/PyQtWebEngine')
-rw-r--r--dev-python/PyQtWebEngine/Manifest1
-rw-r--r--dev-python/PyQtWebEngine/PyQtWebEngine-5.13.2.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/dev-python/PyQtWebEngine/Manifest b/dev-python/PyQtWebEngine/Manifest
index d7555f2b0b73..8970a7199ab4 100644
--- a/dev-python/PyQtWebEngine/Manifest
+++ b/dev-python/PyQtWebEngine/Manifest
@@ -1,2 +1 @@
-DIST PyQtWebEngine-5.13.2.tar.gz 45234 BLAKE2B 4ad3aa63856cf3627c2f4ba29d93394f13297deb5e54bdd200bd419f71322d541ae72e45d70cff09cc53808f0d2430f8922d44f18bbf177c42a6b9c827854d6e SHA512 778aff78ea731230029e8dd993f4bc59a32bf74d65f06a8b3d1467efdc67e3b3caf0d9a968682c6c275c8ffdb8d85d9c756cb51727769949656620e944c736d3
DIST PyQtWebEngine-5.14.0.tar.gz 47794 BLAKE2B 28f4a577ab5d8c1bea439b11e836008d27b4a49f31f230885013b515147a95c97e398328d1fc3a99619c3fd6eca3da7e94bf5873de9ac6511e0f59e467d4490c SHA512 c5274ce5ba1c80c6851971c3e18acf33121cd5863f613bd1789fdb40323b52429b55b54f3dcbb3127c85343e11f14c004ad54711b2b59cab95fd440f90fe5f2e
diff --git a/dev-python/PyQtWebEngine/PyQtWebEngine-5.13.2.ebuild b/dev-python/PyQtWebEngine/PyQtWebEngine-5.13.2.ebuild
deleted file mode 100644
index 273eb83ef2ed..000000000000
--- a/dev-python/PyQtWebEngine/PyQtWebEngine-5.13.2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
-inherit python-r1 qmake-utils
-
-DESCRIPTION="Python bindings for QtWebEngine"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqtwebengine/intro"
-
-MY_P=${PN}-${PV/_pre/.dev}
-if [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
-else
- SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${PN}/${PV}/${MY_P}.tar.gz"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-IUSE="debug"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
-"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-python/PyQt5-5.13.1[gui,network,printsupport,ssl,webchannel,widgets,${PYTHON_USEDEP}]
- >=dev-python/PyQt5-sip-4.19.14:=[${PYTHON_USEDEP}]
- dev-qt/qtcore:5
- dev-qt/qtwebengine:5[widgets]
-"
-DEPEND="${RDEPEND}
- >=dev-python/sip-4.19.14[${PYTHON_USEDEP}]
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_configure() {
- configuration() {
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- --qmake="$(qt5_get_bindir)"/qmake
- $(usex debug '--debug --trace' '')
- --verbose
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- # Fix parallel install failure
- sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_pep484_stubs install_api' \
- ${PN}.pro || die
-
- # Run eqmake to respect toolchain and build flags
- eqmake5 -recursive ${PN}.pro
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- emake INSTALL_ROOT="${D}" install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- einstalldocs
-}