summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-21 18:08:45 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-21 18:08:56 +0200
commit66e7b25d79ffd8ac927a939a6ce23a031cdb9897 (patch)
treebd2de69681df0f0d17d02083d3e4ffac9ae06a80 /dev-python/QtPy
parentgames-emulation/mupen64plus-core: Fix building against opencv-4 (diff)
downloadgentoo-66e7b25d79ffd8ac927a939a6ce23a031cdb9897.tar.gz
gentoo-66e7b25d79ffd8ac927a939a6ce23a031cdb9897.tar.bz2
gentoo-66e7b25d79ffd8ac927a939a6ce23a031cdb9897.zip
dev-python/QtPy: drop webkit dep
It is deprecated, and the tests will work either way because things which are not found are automatically skipped. Also require both pyqt5 and pyside2 to be set if we want to run tests, because it won't work if one of them is disabled. Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/QtPy')
-rw-r--r--dev-python/QtPy/QtPy-1.9.0-r4.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/QtPy/QtPy-1.9.0-r4.ebuild b/dev-python/QtPy/QtPy-1.9.0-r4.ebuild
index b31189ce6bd2..0aa58b9aaab0 100644
--- a/dev-python/QtPy/QtPy-1.9.0-r4.ebuild
+++ b/dev-python/QtPy/QtPy-1.9.0-r4.ebuild
@@ -23,7 +23,10 @@ _IUSE_QT_MODULES="
IUSE="+pyqt5 pyside2 ${_IUSE_QT_MODULES}"
unset _IUSE_QT_MODULES
-REQUIRED_USE="|| ( pyqt5 pyside2 )"
+REQUIRED_USE="
+ || ( pyqt5 pyside2 )
+ test? ( pyqt5 pyside2 )
+"
# These flags are currently *not* common to both the PySide2 and PyQt5 ebuild
# Disable them for now, please check periodically if this is still up to date.
@@ -89,7 +92,7 @@ BDEPEND="
dev-python/PyQt5[bluetooth,dbus,declarative,designer,gui,help,location]
dev-python/PyQt5[multimedia,network,networkauth,opengl,positioning]
dev-python/PyQt5[printsupport,sensors,serialport,sql,svg,testlib]
- dev-python/PyQt5[webchannel,webkit,websockets,widgets,x11extras,xml(+)]
+ dev-python/PyQt5[webchannel,websockets,widgets,x11extras,xml(+)]
dev-python/PyQt5[xmlpatterns]
dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
dev-python/pyside2[${PYTHON_USEDEP}]