summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2016-06-16 14:23:14 -0700
committerPatrick McLean <chutzpah@gentoo.org>2016-06-16 16:43:00 -0700
commit70445ac19bdbfc96b2b0d10ae10ef6f140ad05b1 (patch)
treef13c74a79f854b6882eec52be5a51135273a8e9c /dev-python/SaltTesting/SaltTesting-2016.5.11.ebuild
parentnet-fs/autofs-5.1.1-r1: amd64 stable (diff)
downloadgentoo-70445ac19bdbfc96b2b0d10ae10ef6f140ad05b1.tar.gz
gentoo-70445ac19bdbfc96b2b0d10ae10ef6f140ad05b1.tar.bz2
gentoo-70445ac19bdbfc96b2b0d10ae10ef6f140ad05b1.zip
dev-python/SaltTesting: Version bump to 2016.5.11
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/SaltTesting/SaltTesting-2016.5.11.ebuild')
-rw-r--r--dev-python/SaltTesting/SaltTesting-2016.5.11.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/SaltTesting/SaltTesting-2016.5.11.ebuild b/dev-python/SaltTesting/SaltTesting-2016.5.11.ebuild
new file mode 100644
index 000000000000..9f0835cfd814
--- /dev/null
+++ b/dev-python/SaltTesting/SaltTesting-2016.5.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Required testing tools needed in the several Salt Stack projects"
+HOMEPAGE="http://saltstack.org/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/saltstack/salt-testing.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ >=dev-python/requests-2.4.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"