summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-14 04:44:46 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-14 04:57:59 -0500
commitf10824a259721addcde8ae65d21d7b2ac72b8603 (patch)
tree6a42d5a203c7446dbf47bd0b7b1e30ccf81fd769 /dev-python/adblock
parentnet-misc/clusterssh: Drop 4.03.03 (EAPI 5--) (diff)
downloadgentoo-f10824a259721addcde8ae65d21d7b2ac72b8603.tar.gz
gentoo-f10824a259721addcde8ae65d21d7b2ac72b8603.tar.bz2
gentoo-f10824a259721addcde8ae65d21d7b2ac72b8603.zip
dev-python/adblock: pass --skip-auditwheel to maturin
Without it maturin attempts to look at linked libraries and bundle them within the wheel (using patchelf to find them), and on musl it thinks it should bundle libgcc_s.so. This is also in a scenerio where we don't install using this wheel. May prevent future issues on glibc as well, so unconditionally pass. Option is valid for stable ~maturin-0.11.5 as well, albeit it doesn't do this nor use patchelf and wasn't necessary. Closes: https://bugs.gentoo.org/831171 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/adblock')
-rw-r--r--dev-python/adblock/adblock-0.5.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/adblock/adblock-0.5.1.ebuild b/dev-python/adblock/adblock-0.5.1.ebuild
index ed820b8a8806..bbe06f214840 100644
--- a/dev-python/adblock/adblock-0.5.1.ebuild
+++ b/dev-python/adblock/adblock-0.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -95,7 +95,7 @@ BDEPEND="
QA_FLAGS_IGNORED=".*/site-packages/${PN}/${PN}.abi3.so"
src_compile() {
- maturin build $(usev !debug --release) --no-sdist || die
+ maturin build $(usev !debug --release) --no-sdist --skip-auditwheel || die
mv target/$(usex debug{,} release)/lib${PN}.so ${PN}/${PN}.abi3.so || die
}