summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-26 07:55:55 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-26 11:46:19 +0100
commit1d7c7e65f3504498ecb5a1eada7d8439f8908985 (patch)
tree775e5557902aa04947fda44332ee36ab9629fdef /dev-python/aesara
parentapp-doc/kicad-doc: change IUSE default to +html, not +pdf in 6.0.0_rc1 (diff)
downloadgentoo-1d7c7e65f3504498ecb5a1eada7d8439f8908985.tar.gz
gentoo-1d7c7e65f3504498ecb5a1eada7d8439f8908985.tar.bz2
gentoo-1d7c7e65f3504498ecb5a1eada7d8439f8908985.zip
dev-python/aesara: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aesara')
-rw-r--r--dev-python/aesara/Manifest1
-rw-r--r--dev-python/aesara/aesara-2.3.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index 105e5bf3d8bc..0e6b04bca791 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1 +1,2 @@
DIST aesara-rel-2.2.6.tar.gz 8180674 BLAKE2B 6d2c237a748aeee524e4182c47b17a9f7e7325d94410f8c9d7e3dea1d22306dbaa32be1b6f3c471baffad30527451772c08eaaed4494bcceba1759e9f7e9c837 SHA512 360f280fb997b33fbcef08a278816e51b26e8ba4f6d9b0681984394f293d342b498d4633d5efc1b92d64b056b4cd63b918ea7dd46d00aa78519e00919586f842
+DIST aesara-rel-2.3.0.tar.gz 8181754 BLAKE2B 7fd60e6ce1243e585a4256f807615a4d120833ed3da2f1b16dbcade99950cc470c0b9df2b3a0e481b1694b9fa17b8de5ce30eeeb53e19b0a3244cc44c199e152 SHA512 1198e6a827210e17febc073d60d84e6e2fb044767a573c1569bacbc2bc3181e5d0820349ca90eafdfd83818b97cda9d3d91c42734c6fb9f8452ce5d24d130543
diff --git a/dev-python/aesara/aesara-2.3.0.ebuild b/dev-python/aesara/aesara-2.3.0.ebuild
new file mode 100644
index 000000000000..808493f3123a
--- /dev/null
+++ b/dev-python/aesara/aesara-2.3.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 multiprocessing optfeature
+
+MY_P=aesara-rel-${PV}
+DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
+HOMEPAGE="https://github.com/aesara-devs/aesara"
+SRC_URI="https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e "s/tests.\*/tests\*/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local exclude=(
+ # speed tests are unreliable
+ tests/scan/test_basic.py::test_speed
+ tests/scan/test_basic.py::test_speed_rnn
+ tests/scan/test_basic.py::test_speed_batchrnn
+ tests/link/test_vm.py::test_speed
+ tests/link/test_vm.py::test_speed_lazy
+ tests/tensor/test_gc.py::test_merge_opt_runtime
+
+ # rounding problem?
+ # https://github.com/aesara-devs/aesara/issues/477
+ tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
+ tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
+ )
+
+ distutils_install_for_testing
+ # we do not package numba
+ epytest ${exclude[@]/#/--deselect } \
+ --ignore tests/link/test_numba.py \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+# https://dev.gentoo.org/~mgorny/python-guide/concept.html#packaging-pkgutil-style-namespaces-in-gentoo
+python_install() {
+ rm "${BUILD_DIR}"/lib/bin/__init__.py || die
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}