summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-16 08:43:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-16 13:30:07 +0200
commita2bb5a7b409ce677b910dc68516fb44e59d42c41 (patch)
treea7397e9aa87163330b54d228ae5feb536b8ab131 /dev-python/aesara
parentx11-wm/xpra: eutils-- (diff)
downloadgentoo-a2bb5a7b409ce677b910dc68516fb44e59d42c41.tar.gz
gentoo-a2bb5a7b409ce677b910dc68516fb44e59d42c41.tar.bz2
gentoo-a2bb5a7b409ce677b910dc68516fb44e59d42c41.zip
dev-python/aesara: Bump to 2.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aesara')
-rw-r--r--dev-python/aesara/Manifest1
-rw-r--r--dev-python/aesara/aesara-2.0.7.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index 6df6c24ff22f..ccc3e7157247 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -4,3 +4,4 @@ DIST aesara-rel-2.0.3.tar.gz 8019978 BLAKE2B 5e3a7cdca08569a06b7731ff55894c61859
DIST aesara-rel-2.0.4.tar.gz 8020138 BLAKE2B 4fa1d0d1979eaac1635cd09d9af61ae4be0cbac3722c37cba54a81a93f358f72a7b6c543e2f8c4b120262469e27f96273bffb9222a2c36f58284bc5b7c148d89 SHA512 8205cbbdfb2ce901ea4991a2dc82a8809d1151b2a8da9382cb5306ecb916793c927f8e7c057cc32145802625883476d6a69b5e19b69a69bc843b0114775918ae
DIST aesara-rel-2.0.5.tar.gz 8020447 BLAKE2B 97a08e01b06fa6ce86d0d81fa02a9bc9bb9d7f25c2bfe25e68d46864519899f5a530871a6ca8e07a64732239207869fe88ca235e2ba102aa0eae8360310234cd SHA512 dc69c7e1f5dc30c5e29bf37957ca3e84d370cce054d61656b44398324385a7490d7b6f4edaffd0019196e2a413124b05f44b9b7c618851a51247bc6b79559849
DIST aesara-rel-2.0.6.tar.gz 8020607 BLAKE2B 0a51936fe089061038e9dd60e210d7a0820438a03508fb1aa7f843c9c3dbba86295a7e0471f97084e7ba87e2a771bb640a6f87ce974b219767d2344e2a94b190 SHA512 1370cb4408b694d5b97610229951cfa9e74f42c10347eff375d5aba0aaa60a7c88f5db2a7c101ec6916a40d6cf12b5646e7422dd5e9617f414619d79c55f02fb
+DIST aesara-rel-2.0.7.tar.gz 8020485 BLAKE2B 91c02c5d6826694b08bf3276f9c08e98f5a68a34b7d4a4f4813b44794f625cb0b67677fc8eff8496f19f84b462b30d740645b19b3031640a550b8b07288980ef SHA512 63f636d7293127b21196072fd05edf25f2d03702d5568308ddb35c2d425100aa4087eb282f30a123124e43bedbc82d84209293c2d2de6f598c7b3b6704fc38aa
diff --git a/dev-python/aesara/aesara-2.0.7.ebuild b/dev-python/aesara/aesara-2.0.7.ebuild
new file mode 100644
index 000000000000..ddca7befcd2d
--- /dev/null
+++ b/dev-python/aesara/aesara-2.0.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1 optfeature
+
+MY_P=aesara-rel-${PV}
+DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
+HOMEPAGE="https://github.com/pymc-devs/aesara"
+SRC_URI="https://github.com/pymc-devs/aesara/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e "s/tests.\*/tests\*/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local exclude=(
+ # speed tests are unreliable
+ tests/scan/test_basic.py::test_speed
+ tests/scan/test_basic.py::test_speed_rnn
+ tests/scan/test_basic.py::test_speed_batchrnn
+ tests/link/test_vm.py::test_speed
+ tests/link/test_vm.py::test_speed_lazy
+ tests/tensor/test_gc.py::test_merge_opt_runtime
+ )
+
+ distutils_install_for_testing --via-root
+ epytest ${exclude[@]/#/--deselect } \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+# https://dev.gentoo.org/~mgorny/python-guide/concept.html#packaging-pkgutil-style-namespaces-in-gentoo
+python_install() {
+ rm "${BUILD_DIR}"/lib/bin/__init__.py || die
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}