summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-06-21 16:23:54 -0700
committerZac Medico <zmedico@gentoo.org>2021-06-21 16:32:43 -0700
commit11c0d4017460fbdecea2209280d790310db6e98a (patch)
treef59174bba5017e44d1c2bd39921a8c19b0c4d190 /dev-python/agate
parentdev-python/grpcio-testing: drop 1.38.0 (diff)
downloadgentoo-11c0d4017460fbdecea2209280d790310db6e98a.tar.gz
gentoo-11c0d4017460fbdecea2209280d790310db6e98a.tar.bz2
gentoo-11c0d4017460fbdecea2209280d790310db6e98a.zip
dev-python/agate: Comment on details of xfails skipped via epytest --deselect
test_cast_format_locale fails with "locale.Error: unsupported locale setting" which appears to be triggered by these locale settings in the unit tests: agate-1.6.2/tests/test_data_types.py:257: def test_cast_format_locale(self): agate-1.6.2/tests/test_data_types.py-258- date_type = Date(date_format='%d-%b-%Y', locale='de_DE') agate-1.6.2/tests/test_data_types.py:381: def test_cast_format_locale(self): agate-1.6.2/tests/test_data_types.py-382- date_type = DateTime(datetime_format='%Y-%m-%d %I:%M %p', locale='ko_KR') Bug: https://bugs.gentoo.org/797307 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/agate')
-rw-r--r--dev-python/agate/agate-1.6.2.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/agate/agate-1.6.2.ebuild b/dev-python/agate/agate-1.6.2.ebuild
index eaa3487a523c..390df28bbaba 100644
--- a/dev-python/agate/agate-1.6.2.ebuild
+++ b/dev-python/agate/agate-1.6.2.ebuild
@@ -45,6 +45,14 @@ pytest-expect-to-deselect() {
}
python_test() {
+ # test_cast_format_locale fails with "locale.Error: unsupported locale setting"
+ # which appears to be triggered by these locale settings in the unit tests:
+ #
+ # agate-1.6.2/tests/test_data_types.py:257: def test_cast_format_locale(self):
+ # agate-1.6.2/tests/test_data_types.py-258- date_type = Date(date_format='%d-%b-%Y', locale='de_DE')
+ # agate-1.6.2/tests/test_data_types.py:381: def test_cast_format_locale(self):
+ # agate-1.6.2/tests/test_data_types.py-382- date_type = DateTime(datetime_format='%Y-%m-%d %I:%M %p', locale='ko_KR')
+
local -a pytest_args
readarray -t pytest_args < <(pytest-expect-to-deselect <<<"
pytest-expect file v1