summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-08 22:57:30 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-09 09:34:09 +0300
commitdff1bf4a87061d0a6e6d97aec748defc765dc8ef (patch)
treefacaab2964060075aeb150385f2ce9e7ee0d88ee /dev-python/agate
parentdev-python/leather: drop 0.3.3-r2 (diff)
downloadgentoo-dff1bf4a87061d0a6e6d97aec748defc765dc8ef.tar.gz
gentoo-dff1bf4a87061d0a6e6d97aec748defc765dc8ef.tar.bz2
gentoo-dff1bf4a87061d0a6e6d97aec748defc765dc8ef.zip
dev-python/agate: remove IUSE=xml
- remove IUSE="xml" as it was used as gateway for test dependencies. - use new EPYTEST_DESELECT Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/agate')
-rw-r--r--dev-python/agate/agate-1.6.3-r1.ebuild (renamed from dev-python/agate/agate-1.6.3.ebuild)23
1 files changed, 7 insertions, 16 deletions
diff --git a/dev-python/agate/agate-1.6.3.ebuild b/dev-python/agate/agate-1.6.3-r1.ebuild
index 92bdd1023bf1..a55081099558 100644
--- a/dev-python/agate/agate-1.6.3.ebuild
+++ b/dev-python/agate/agate-1.6.3-r1.ebuild
@@ -13,11 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+xml"
-# Other packages have BDEPEND="test? ( dev-python/agate[xml] )"
-LEATHER_VERSION_DEP=">=dev-python/leather-0.3.3-r2"
-TEST_AGAINST_RDEPEND="xml? ( ${LEATHER_VERSION_DEP}[xml,${PYTHON_USEDEP}] )"
RDEPEND="
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
>=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
@@ -26,21 +22,16 @@ RDEPEND="
>=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
>=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
>=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
- ${LEATHER_VERSION_DEP}[${PYTHON_USEDEP}]
-
- ${TEST_AGAINST_RDEPEND}
+ >=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
"
-BDEPEND="test? ( ${LEATHER_VERSION_DEP}[xml,${PYTHON_USEDEP}] )"
+BDEPEND="test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest
distutils_enable_sphinx docs \
dev-python/sphinx_rtd_theme
-python_test() {
- local deselect=(
- # require specific locales
- tests/test_data_types.py::TestDate::test_cast_format_locale
- tests/test_data_types.py::TestDateTime::test_cast_format_locale
- )
- epytest ${deselect[@]/#/--deselect }
-}
+EPYTEST_DESELECT=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+)