summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-01-27 13:19:29 +0100
committerPacho Ramos <pacho@gentoo.org>2019-01-27 13:35:54 +0100
commitbe937f6bae1f04d3dbd8e1446dada316cf386d13 (patch)
treeffbe0f82615463c499b77d4e6f40b21ffc291324 /dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild
parentdev-libs/sblim-sfcc: Drop old (diff)
downloadgentoo-be937f6bae1f04d3dbd8e1446dada316cf386d13.tar.gz
gentoo-be937f6bae1f04d3dbd8e1446dada316cf386d13.tar.bz2
gentoo-be937f6bae1f04d3dbd8e1446dada316cf386d13.zip
dev-python/aiohttp-cors: Drop old
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild')
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild
deleted file mode 100644
index 280963ec1976..000000000000
--- a/dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
-HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
-SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-EGIT_REPO_URI="https://github.com/aio-libs/aiohttp-cors"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' python3_4)"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-pylint[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/selenium[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # for some reason, it is installed by 'setup.py test' on py!=3.4
- # TODO: investigate
- sed -i -e '/typing/d' setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}