summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-03-03 02:00:36 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-03-03 03:07:08 +0100
commitf0ca06ad3b0145ced9f954674442d2182d2b4a7b (patch)
treeb62ca86eb8e6891b8608bfa796551f80640fa765 /dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild
parentdev-python/aiohttp: Bump to v2.3.10 (diff)
downloadgentoo-f0ca06ad3b0145ced9f954674442d2182d2b4a7b.tar.gz
gentoo-f0ca06ad3b0145ced9f954674442d2182d2b4a7b.tar.bz2
gentoo-f0ca06ad3b0145ced9f954674442d2182d2b4a7b.zip
dev-python/aiohttp-cors: Bump to v0.6.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild')
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild
new file mode 100644
index 000000000000..c50b49783a70
--- /dev/null
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp-cors"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' python3_4)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-pylint[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # for some reason, it is installed by 'setup.py test' on py!=3.4
+ # TODO: investigate
+ sed -i -e '/typing/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}