summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-10-13 16:47:04 -0400
committerCraig Andrews <candrews@gentoo.org>2019-10-15 11:57:53 -0400
commit46ae080a9f899a3ccf4c5ca0ce20aa56b9468c70 (patch)
tree55edafe4feb35e75f668d940d4b980b31e17834f /dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild
parentdev-python/aiohttp-cors: Python 3.7 compatibility (diff)
downloadgentoo-46ae080a9f899a3ccf4c5ca0ce20aa56b9468c70.tar.gz
gentoo-46ae080a9f899a3ccf4c5ca0ce20aa56b9468c70.tar.bz2
gentoo-46ae080a9f899a3ccf4c5ca0ce20aa56b9468c70.zip
dev-python/aiohttp-cors: 0.7.0 version bump, EAPI=7
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild')
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild
new file mode 100644
index 000000000000..6bd3345141ef
--- /dev/null
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp-cors"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-pylint[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # for some reason, it is installed by 'setup.py test' on py!=3.4
+ # TODO: investigate
+ sed -i -e '/typing/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}