summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-python/aiohttp-cors
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp-cors')
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild1
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild
index e5b671ad5b8e..6a2b315affe4 100644
--- a/dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild
@@ -16,6 +16,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild
index 6bd3345141ef..eb2e764e7273 100644
--- a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild
@@ -16,6 +16,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}