summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-23 07:57:50 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-23 09:28:57 +0200
commitfa2ea029859e8eecfb7ca743e16c69b4e7f339de (patch)
tree8577ff23e5731048d2938ff8b3d962eb78d56b20 /dev-python/aiohttp-socks
parentdev-python/boto3: Bump to 1.15.3 (diff)
downloadgentoo-fa2ea029859e8eecfb7ca743e16c69b4e7f339de.tar.gz
gentoo-fa2ea029859e8eecfb7ca743e16c69b4e7f339de.tar.bz2
gentoo-fa2ea029859e8eecfb7ca743e16c69b4e7f339de.zip
dev-python/aiohttp-socks: Bump to 0.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp-socks')
-rw-r--r--dev-python/aiohttp-socks/Manifest1
-rw-r--r--dev-python/aiohttp-socks/aiohttp-socks-0.5.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/aiohttp-socks/Manifest b/dev-python/aiohttp-socks/Manifest
index a4ad837143a4..ef6a3f2caaeb 100644
--- a/dev-python/aiohttp-socks/Manifest
+++ b/dev-python/aiohttp-socks/Manifest
@@ -1,2 +1,3 @@
DIST aiohttp-socks-0.5.3.tar.gz 1360418 BLAKE2B 7282a4952d5f0301b14291a1892db5ec058af91cf553e4a17ab0e933bb327d1fae9c015d25ff7405ef69cdf56637140fefa9bd1ab1e6f2e224cdc94b9e279159 SHA512 2999f850081d05c31535c24c0fcf0948dbaaec5e421c28ed4ca68b4bfb122f881942e7e829cefc01377212b4579547aafcf273fe5a999acb3d158ee1c3f0a888
DIST aiohttp-socks-0.5.4.tar.gz 1349276 BLAKE2B 17cfc9a326d45e6af4044ccd0ce56dff3adaddf619118a5a98a6e82c778f5e397780d51924e11ff50d059a60df22cbb1c03b27165042f78d06b242ed95f5f254 SHA512 30ac5544b935f021fbd40aac9df682970a1ed39295dcd64909dce270e66f61fd92933a81a25c79b5063a5b382d412ba7b26def67e1e8c059e8daa2a771342a77
+DIST aiohttp-socks-0.5.5.tar.gz 1349283 BLAKE2B 85cd19fdc8c549a1c8ed66a71a9ccb61093fa6febfc2b2e93e26e47be9fc4d319f0ceecc0d6f70739e861fe5f7cd8c78615dfe67ed0669049d38da1f89da33f2 SHA512 94b9d5fc5a5eb04ce16302ca4a1abdaf8ec2b31811a6156aa3667aeb5bd284fc1757a65dc8dc7b77450017a04aa315a908a52a4d38b0657c41bcd64b9b1605b9
diff --git a/dev-python/aiohttp-socks/aiohttp-socks-0.5.5.ebuild b/dev-python/aiohttp-socks/aiohttp-socks-0.5.5.ebuild
new file mode 100644
index 000000000000..083f5275a69d
--- /dev/null
+++ b/dev-python/aiohttp-socks/aiohttp-socks-0.5.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS proxy connector for aiohttp"
+HOMEPAGE="https://pypi.org/project/aiohttp-socks/"
+SRC_URI="https://github.com/romis2012/aiohttp-socks/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# tests require Internet
+RESTRICT="test"
+
+# TODO: optional dep on trio
+# TODO: is attrs actually used?
+RDEPEND="
+ >=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ dev-python/python-socks[${PYTHON_USEDEP}]
+"
+#DEPEND="
+# test? (
+# dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+# )"
+
+#distutils_enable_tests pytest