summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-11-16 18:21:57 -0800
committerZac Medico <zmedico@gentoo.org>2016-11-16 18:22:50 -0800
commit03728297b5c6b9eeb13a7201b4af2ac9fdac613c (patch)
tree25db6d6c9f0693c1fd02fc253e141da02ae79f6d /dev-python/aiohttp
parentnet-misc/openvpn: Version bump to 2.3.13 (diff)
downloadgentoo-03728297b5c6b9eeb13a7201b4af2ac9fdac613c.tar.gz
gentoo-03728297b5c6b9eeb13a7201b4af2ac9fdac613c.tar.bz2
gentoo-03728297b5c6b9eeb13a7201b4af2ac9fdac613c.zip
dev-python/aiohttp: version bump to 1.1.5
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-1.1.5.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 7e5738509573..276abbce5337 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -4,3 +4,4 @@ DIST aiohttp-1.0.4.tar.gz 562803 SHA256 7e2d4282b2031ca2aaef35d4291743f37a884082
DIST aiohttp-1.0.5.tar.gz 563623 SHA256 053a16d03672cb3055cfac06650d238f55205702207be4a3b40c42333df0ebeb SHA512 f6fe77729a54d817046f0cc952d8906524c2dfe6712dd1972d696680fe34310b6dba9a3b48b6e27c52d3fedd3fa0f541a7c1ac45488b3358e39e3768a01749d9 WHIRLPOOL 51c609bed1bad59e8c1761fa412ed36031da7b80dff03f5edffd84763044cdb570c49d7b9970d133c9b1b224cc293e73004b00447f5b242d91c8286cc21e87c9
DIST aiohttp-1.1.1.tar.gz 575872 SHA256 6f624d2b340a2c622949e5585540373a86349d31c2f6d46cd4d7b8446cf35f4a SHA512 38636ce4547688ade569ebfc0dbc62b769379500451954c528cd5dddfc7e6c25e6397a56382959ecd43c85c2f344039f4140bf91551e90b288fbd2aefdc94823 WHIRLPOOL d08ba4a51ddb8f66ceed6a64b304192635fccca31f9982484d17f4beaee3cb60d341a3101db6fda8d45231bd99e82ee18b3b86270edbbb9312bd9504f360ac43
DIST aiohttp-1.1.2.tar.gz 576160 SHA256 8be33ad39522d5fbc06ce527da4615bf93e6c5d4f933173072bc51fa27ea0cf4 SHA512 ccba7a8e9a2cebaa0afadcfa927fbe9113577b2c69165cd64d8f1169d6cdb4efca252a228ad8d4780b20fcc94fffb9fa8217cbd0d49cbe9c5560a81e4423be41 WHIRLPOOL ea3f9d74f7c4a0d266b56a2cd5a8655734fd8c9043a7b8f5423f960ff90cbaec1b1d6f3965b089d1cb4db7e1abb39a58dd7d5f627e6f88fb292c822ae75ab77a
+DIST aiohttp-1.1.5.tar.gz 577346 SHA256 8f4c31a10b0a96667ac8a13e3756a3505e040c423c3c4075b99745056b3537d8 SHA512 44b1474a64ce150164045f30734da119a1848a3677d885493f99f2d724d20884dac9a24adce4b90017e203fc67b295443f91d14f1af9eb20d657a3cd4b69d747 WHIRLPOOL 036265681123f902aaa2000fd6ddd83980c3b1a48d67b583b5e1da7e7079d381a9c92669c12040c1494ba3890c2a849cd1f190003a1ec611df7a72843242bcec
diff --git a/dev-python/aiohttp/aiohttp-1.1.5.ebuild b/dev-python/aiohttp/aiohttp-1.1.5.ebuild
new file mode 100644
index 000000000000..e63aabe15fe0
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-1.1.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/aiohttp"
+SRC_URI="https://github.com/KeepSafe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/KeepSafe/aiohttp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/multidict-2.0[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${PWD}:${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}