summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-04-24 21:58:34 -0700
committerZac Medico <zmedico@gentoo.org>2017-04-24 22:01:56 -0700
commit24255d98ec70a36d7d0eaccfad6f735da0c2414d (patch)
treeab557b748d2bf86629106c271b4c9706a9c81893 /dev-python/aiohttp
parentdev-python/aiohttp: version bump to 1.3.3 (diff)
downloadgentoo-24255d98ec70a36d7d0eaccfad6f735da0c2414d.tar.gz
gentoo-24255d98ec70a36d7d0eaccfad6f735da0c2414d.tar.bz2
gentoo-24255d98ec70a36d7d0eaccfad6f735da0c2414d.zip
dev-python/aiohttp: drop version 1.3.5 (buggy)
With aiohttp-1.3.5, I've observed CancelledError raised unexpectedly from the aiohttp.ClientSession.get method, and downgrading to 1.3.3 made the problem go away. The traceback with aiohttp-1.3.5 and python-3.5.2 was as follows: File "fetcher.py", line 223, in fetch await await client_session.get(url, timeout=timeout, params=params) File "/usr/lib64/python3.5/asyncio/futures.py", line 361, in __iter__ yield self # This tells Task to wait for completion. File "/usr/lib64/python3.5/asyncio/tasks.py", line 296, in _wakeup future.result() File "/usr/lib64/python3.5/asyncio/futures.py", line 274, in result raise self._exception File "/home/zmedico/repos/adswatch/src/adswatch/rest_client.py", line 124, in _get url, timeout=self._timeout, params=params) File "/usr/lib64/python3.5/site-packages/aiohttp/client.py", line 590, in __await__ resp = yield from self._coro File "/usr/lib64/python3.5/site-packages/aiohttp/client.py", line 217, in _request conn = yield from self._connector.connect(req) File "/usr/lib64/python3.5/site-packages/aiohttp/connector.py", line 370, in connect yield from self._create_connection(req) File "/usr/lib64/python3.5/site-packages/aiohttp/connector.py", line 663, in _create_connection transport, proto = yield from self._create_direct_connection(req) File "/usr/lib64/python3.5/site-packages/aiohttp/connector.py", line 686, in _create_direct_connection local_addr=self._local_addr) File "/usr/lib64/python3.5/asyncio/base_events.py", line 649, in create_connection yield from tasks.wait(fs, loop=self) File "/usr/lib64/python3.5/asyncio/tasks.py", line 347, in wait return (yield from _wait(fs, timeout, return_when, loop)) File "/usr/lib64/python3.5/asyncio/tasks.py", line 430, in _wait yield from waiter File "/usr/lib64/python3.5/asyncio/futures.py", line 361, in __iter__ yield self # This tells Task to wait for completion. File "/usr/lib64/python3.5/asyncio/tasks.py", line 296, in _wakeup future.result() File "/usr/lib64/python3.5/asyncio/futures.py", line 266, in result raise CancelledError concurrent.futures._base.CancelledError Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-1.3.5.ebuild68
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 254dcd880c2b..fd6db4e7e4ad 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -7,4 +7,3 @@ DIST aiohttp-1.1.2.tar.gz 576160 SHA256 8be33ad39522d5fbc06ce527da4615bf93e6c5d4
DIST aiohttp-1.1.5.tar.gz 577346 SHA256 8f4c31a10b0a96667ac8a13e3756a3505e040c423c3c4075b99745056b3537d8 SHA512 44b1474a64ce150164045f30734da119a1848a3677d885493f99f2d724d20884dac9a24adce4b90017e203fc67b295443f91d14f1af9eb20d657a3cd4b69d747 WHIRLPOOL 036265681123f902aaa2000fd6ddd83980c3b1a48d67b583b5e1da7e7079d381a9c92669c12040c1494ba3890c2a849cd1f190003a1ec611df7a72843242bcec
DIST aiohttp-1.2.0.tar.gz 589818 SHA256 b2fa11df067207ff15813be84b78910f6f9d897f02e9c345993b9962802a6bea SHA512 4101f0aad0d6bb8caf931dbd7f9e07bfdaa445796af92c84ea999538c2767f3cd62740ea9c7e07f255eb57b52e967e5343461809a5d5f4e8b12cd4383753bd77 WHIRLPOOL 239f802ce1dde24b3e1c6fba39357822564256f1aae167b44164d9bab3e67113400534df0835ca6b5245b8229dcab752149774c7adde1e1aef2a0f549d2d33ad
DIST aiohttp-1.3.3.tar.gz 526273 SHA256 103433f594442b98ed4af9db02331e548a0ef2d4cfd02207ea24ed9eb85862e4 SHA512 39342270f615f7e5e01889ad50ccb60335151e94631007b105acda9930038d2fb66128469ca44043280c9f737130e2361129e2fa1c857a7654a1151b98a19a69 WHIRLPOOL c6689d990f31ce45e012ca26a459993505d264fdb36f87481588eb747e5cd5c5aa38dd2e08c10f2d9b7bfd16622a7b312e08c7fb7c33929e0bdf872fac2e92bf
-DIST aiohttp-1.3.5.tar.gz 527432 SHA256 cd14a45da385b5e860849ffaff3ecee56f9b37bf9e7f3f7bc5ce3f17556cf842 SHA512 b99630fa9006163d61e0e010972aee8daad021c5ad0152b04fb6f8b661f18ea03fcfa8d35603ecfcdaef4ecbaff0159b49e2f40164241bb5def48b2847e2d966 WHIRLPOOL b39e5a5081cadb497aa982b8bee1a24615a2e382071755586c52855529c7984c9140c04239fe9ef81e51f3e11a1ea7b1c021f6b8a4dd58c4d826f934394b5576
diff --git a/dev-python/aiohttp/aiohttp-1.3.5.ebuild b/dev-python/aiohttp/aiohttp-1.3.5.ebuild
deleted file mode 100644
index 0070d6eeb7f3..000000000000
--- a/dev-python/aiohttp/aiohttp-1.3.5.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="http client/server for asyncio"
-HOMEPAGE="https://pypi.python.org/pypi/aiohttp"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
-EGIT_REPO_URI="https://github.com/aio-libs/aiohttp"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-CDEPEND="
- dev-python/async_timeout[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- >=dev-python/multidict-2.1.4[${PYTHON_USEDEP}]
- >=dev-python/yarl-0.9.8[${PYTHON_USEDEP}]
- <dev-python/yarl-0.10[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- ${CDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- www-servers/gunicorn[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- sed -e 's|^ self.pid = '\''pid'\'$'|\
- try:\
- self.pid = '\''pid'\''\
- except:\
- pass|' -i tests/test_worker.py || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH="${PWD}:${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}