summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-03-27 09:20:05 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-03-27 09:21:57 -0500
commit8262a3fe7c84af5b391c489011abe577bbc6812d (patch)
tree0ce71f477493f1ef37e76aef516d87464892b53f /dev-python/aiohttp
parentdev-libs/yajl: fix tests (diff)
downloadgentoo-8262a3fe7c84af5b391c489011abe577bbc6812d.tar.gz
gentoo-8262a3fe7c84af5b391c489011abe577bbc6812d.tar.bz2
gentoo-8262a3fe7c84af5b391c489011abe577bbc6812d.zip
dev-python/aiohttp: add version 0.21.4
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-0.21.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 8e138775eb96..a1eedffe5df7 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -2,3 +2,4 @@ DIST aiohttp-0.17.4.tar.gz 475034 SHA256 a2f122b41f29eb10772f1600ada5fec849c5dc7
DIST aiohttp-0.18.4.tar.gz 2165117 SHA256 23f1a5de84d0384ab2e78405db56be5e4af0681c42ddbc0caecf2402ddee3019 SHA512 ae4d72d661b2e69e9eb9d258d3c8842cd3e7a8a1d71dd71ccfbc7a3cf5916d65c82f3e3fe56731d5a326d810c01c32dbcb88900b7db68f3f5172c15e482aadc4 WHIRLPOOL 6b59b45e510472c8082868025e660c98e509760d87d08962b7fcc29680e1e31d89bf4e15d2559c7f202ebe70a28cc9eae4908c999cc7c0c29e4b6ea4ed2fbaaf
DIST aiohttp-0.19.0.tar.gz 2173954 SHA256 9bfb173baec179431a1c8f3566185e8ebbd1517cf4450217087d79e26e44c287 SHA512 4e20d9e4eac4bd11538faa8a2b9ad6d65b432cb0bc468b851aebc32b6ac15417e65bf68c5801efb2911562f63ba2cd3da31e9cb8347e5aa8f840ba91a986061f WHIRLPOOL 9db94601eec1ff2b5bdbcf04b662a3f7f7d04c24f742d30244bc90d5390f9ae1c303c8de3a0ad253ff7aa068f07a9e439fb0ccadb80db1ba57f6ac3620a1621b
DIST aiohttp-0.20.2.tar.gz 513968 SHA256 8801d36d760514ba8404d2c0309a7ecc3a838b85dad3e63e863b44a3116cf02b SHA512 378b867ed531a1f30079b9a42d4000b82efe997b1e1bee3f1c76973712eabf973da74b37b969d43929f18a8b99ac004a22c4b7849bed1f00fe2f88c0bfbcdddb WHIRLPOOL 8853c2c5f8efde97caff2ba99ef44e505dc82a206ecc51028c7db1b95c4232d436acb9109794ca259e4423d83238569f8df7bdfe81f3131321cebbde00f1d068
+DIST aiohttp-0.21.4.tar.gz 528945 SHA256 4a5fcb765bf6d2cbc7d42afedf3d22b9cd0a4d643a870b464ca5b071225976d8 SHA512 e9abc66e1f6ba81b94ef5a528e3bca58434f6d30242967a6b69e66ea164a31d076dbd2159b464c6a59c219483e81febfba986066863f6a3811ff0dc8a51adb64 WHIRLPOOL d9f26b397b63d18e32cc754c75078e97cb6b4d3e2400ade75d91f86890e82407302bc2d55e2a30fe8d2bee7dd99fef16e528cf2c9668998662049543a671da66
diff --git a/dev-python/aiohttp/aiohttp-0.21.4.ebuild b/dev-python/aiohttp/aiohttp-0.21.4.ebuild
new file mode 100644
index 000000000000..ab8be7d6cd66
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-0.21.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://github.com/KeepSafe/aiohttp https://pypi.python.org/pypi/aiohttp"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+CDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-raisesregexp[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="$(PWD):${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}