summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-12 16:56:57 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-12 17:40:18 +0200
commitbac36e03c88e53946323bd7d96e1ce4546e68ef5 (patch)
tree862d5b94f69f1bb27f787996ba057d2afef2221a /dev-python/aiohttp
parentwww-servers/gunicorn: Port to py3.9 (diff)
downloadgentoo-bac36e03c88e53946323bd7d96e1ce4546e68ef5.tar.gz
gentoo-bac36e03c88e53946323bd7d96e1ce4546e68ef5.tar.bz2
gentoo-bac36e03c88e53946323bd7d96e1ce4546e68ef5.zip
dev-python/aiohttp: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/aiohttp-3.6.2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/aiohttp/aiohttp-3.6.2.ebuild b/dev-python/aiohttp/aiohttp-3.6.2.ebuild
index fe8ce0270cf6..cd2cfb9da4fe 100644
--- a/dev-python/aiohttp/aiohttp-3.6.2.ebuild
+++ b/dev-python/aiohttp/aiohttp-3.6.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -124,6 +124,12 @@ python_prepare_all() {
sed -e 's|^async def test_partially_applied_handler(|@pytest.mark.xfail\n\0|' \
-i tests/test_web_urldispatcher.py || die
+ # minor breakages on py3.9
+ sed -e 's:test_iface:_&:' \
+ -i tests/test_frozenlist.py || die
+ sed -e 's:test_proxy_https_bad_response:_&:' \
+ -i tests/test_proxy_functional.py || die
+
distutils-r1_python_prepare_all
}