summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-01 10:40:22 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-01 10:40:22 +0100
commit64a4e3b7c60bf6f69ab7e19da831eda9c867f5cb (patch)
treeb576a5bb3f5040960691cc12c3a38d8ae7d483ef /dev-python/aiorpcX
parentnet-analyzer/zabbix: removed obsolete 4.0.27-r1, 5.0.7 & 5.2.3 (diff)
downloadgentoo-64a4e3b7c60bf6f69ab7e19da831eda9c867f5cb.tar.gz
gentoo-64a4e3b7c60bf6f69ab7e19da831eda9c867f5cb.tar.bz2
gentoo-64a4e3b7c60bf6f69ab7e19da831eda9c867f5cb.zip
dev-python/aiorpcX: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiorpcX')
-rw-r--r--dev-python/aiorpcX/Manifest1
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.18.4-r1.ebuild37
-rw-r--r--dev-python/aiorpcX/files/aiorpcX-0.18.4-py38.patch53
3 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/aiorpcX/Manifest b/dev-python/aiorpcX/Manifest
index 596ccbf5c60d..5cc7d9fc31c1 100644
--- a/dev-python/aiorpcX/Manifest
+++ b/dev-python/aiorpcX/Manifest
@@ -1,4 +1,3 @@
-DIST aiorpcX-0.18.4.gh.tar.gz 65500 BLAKE2B 8c84ace1e2bc974e68702e25efe126f7f69dd7451f438ccd924ee8be3c0cccc5c9b3d116bf2d0a755b013bdfe61a398d856031970e5ae82b571af09551231bed SHA512 d4df1343f575af72dff31f1794485c0cbb5b6c31d6d933b07cc8375a1418ad4fb81b2649b3c60adaaeab75b7a5d959838accc38269373310eb07895acf4c9496
DIST aiorpcX-0.18.5.gh.tar.gz 65622 BLAKE2B 68b91e2cfb869c6971efb525fd35132c38ab9092362944fa77476bdb33f076f8415a079d97238e2c4ffbc6c9df596b468c2b6640389a11d1607b1a99aa8dc68d SHA512 5eb8417ce2ffb70208aec79e44ee0d8671c4cf86745f2d8061cf013c4ad17f83db68ed3ed43ef61df196e4ef073a21f9a4e22df46b00ce3054babf98dfcd1eaf
DIST aiorpcX-0.19.1.gh.tar.gz 72903 BLAKE2B ba3da1bc1f8d83ec6c6d2189aee554b4b819b601d366d0e8858ec73fe6aedddf6a6ed00d56d66c38d18ee44921a4cce7cb83ebf05aec9348355f88b8ed67e1a5 SHA512 b71edf335ad78b1d46b2b23dcb102b29f988d32f75571b881e2ce3471bf48c7ffc9bf509ce1cafec036662bb06d6f90598304c207f416b4124a7b02fdca915e8
DIST aiorpcX-0.19.gh.tar.gz 65557 BLAKE2B 2bc9d809abbcdcf4dd0358e4bb734068ef76482dc711e1c4568db78e9ae2141e00cffb82c1c7d5976887e0561b6c4f1422063969cec23a886bb192c279fc57d7 SHA512 21d8a75a90233bb4caed804da39274516a7c852c8adf9eabcba928ff7ad9bf922760fdca2c040aad8242193cb23be512803615973256b35347b6c998cccd6632
diff --git a/dev-python/aiorpcX/aiorpcX-0.18.4-r1.ebuild b/dev-python/aiorpcX/aiorpcX-0.18.4-r1.ebuild
deleted file mode 100644
index 7cd487159a20..000000000000
--- a/dev-python/aiorpcX/aiorpcX-0.18.4-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
-HOMEPAGE="https://pypi.org/project/aiorpcX/
- https://github.com/kyuupichan/aiorpcX/"
-SRC_URI="https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-BDEPEND="
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/uvloop[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-py38.patch
-)
-
-src_prepare() {
- # websockets are optional and not packaged in Gentoo
- rm tests/test_websocket.py || die
-
- distutils-r1_src_prepare
-}
diff --git a/dev-python/aiorpcX/files/aiorpcX-0.18.4-py38.patch b/dev-python/aiorpcX/files/aiorpcX-0.18.4-py38.patch
deleted file mode 100644
index bc189277c4c6..000000000000
--- a/dev-python/aiorpcX/files/aiorpcX-0.18.4-py38.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/aiorpcx/socks.py b/aiorpcx/socks.py
-index 92ad396..4a6cefa 100644
---- a/aiorpcx/socks.py
-+++ b/aiorpcx/socks.py
-@@ -45,7 +45,7 @@ SOCKSUserAuth = collections.namedtuple("SOCKSUserAuth", "username password")
-
- # Random authentication is useful when used with Tor for stream isolation.
- class SOCKSRandomAuth(SOCKSUserAuth):
-- def __getitem__(self, key):
-+ def __getattribute__(self, key):
- return secrets.token_hex(32)
-
-
-diff --git a/tests/test_curio.py b/tests/test_curio.py
-index 9292f52..97b479b 100644
---- a/tests/test_curio.py
-+++ b/tests/test_curio.py
-@@ -1,4 +1,5 @@
- from asyncio import get_event_loop, InvalidStateError
-+import sys
- import time
-
- import pytest
-@@ -525,6 +526,8 @@ async def test_nested_context_timeout():
- ]
-
-
-+@pytest.mark.xfail(sys.hexversion > 0x03080000,
-+ reason='broken on py3.8, upstream ignores the problem')
- @pytest.mark.asyncio
- async def test_nested_context_timeout2():
- async def coro1():
-@@ -562,6 +565,8 @@ async def test_nested_context_timeout2():
- await parent()
-
-
-+@pytest.mark.xfail(sys.hexversion > 0x03080000,
-+ reason='broken on py3.8, upstream ignores the problem')
- @pytest.mark.asyncio
- async def test_nested_context_timeout3():
- async def coro1():
-diff --git a/tests/test_jsonrpc.py b/tests/test_jsonrpc.py
-index 315f639..b0cdd60 100644
---- a/tests/test_jsonrpc.py
-+++ b/tests/test_jsonrpc.py
-@@ -1126,7 +1126,6 @@ def test_handler_invocation():
- (Request('missing_method', []), 'unknown method'),
- (Request('add_many', []), 'requires 1'),
- (Request('add_many', {'first': 1, 'values': []}), 'values'),
-- (Request('powb', {"x": 2, "y": 3}), 'cannot be called'),
- (Request('echo_2', ['ping', 'pong']), 'at most 1'),
- (Request('echo_2', {'first': 1, 'second': 8, '3rd': 1}), '3rd'),
- (Request('kwargs', []), 'requires 1'),