summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-26 08:11:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-26 10:19:02 +0200
commit78e009913537d31285ee6740e2e4955f0335e057 (patch)
tree793b47da45dfd160fa3d3c8c8d6e816420fefc62 /dev-python/aiorpcX
parentdev-python/awscli: Bump to 1.19.80 (diff)
downloadgentoo-78e009913537d31285ee6740e2e4955f0335e057.tar.gz
gentoo-78e009913537d31285ee6740e2e4955f0335e057.tar.bz2
gentoo-78e009913537d31285ee6740e2e4955f0335e057.zip
dev-python/aiorpcX: Bump to 0.22.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiorpcX')
-rw-r--r--dev-python/aiorpcX/Manifest1
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.22.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/aiorpcX/Manifest b/dev-python/aiorpcX/Manifest
index 32dff034f656..42fcee3b10f4 100644
--- a/dev-python/aiorpcX/Manifest
+++ b/dev-python/aiorpcX/Manifest
@@ -3,3 +3,4 @@ DIST aiorpcX-0.19.1.gh.tar.gz 72903 BLAKE2B ba3da1bc1f8d83ec6c6d2189aee554b4b819
DIST aiorpcX-0.20.2.gh.tar.gz 74627 BLAKE2B e5a33dfd8ef0c18e26cfee881fd7515437598628bf61dfd86a34f0a758474abcf257c7afcbf0ee1d11ed6bad44596289efe2261d9ca7ccc26e7d949f05b3ad40 SHA512 af63d51bd21a045d71073ba6cd030834f8262e393eac9c44e6b33a2b3cecd86a5d2a6a0ed7ab60d2362e99ab38c801abcae1ada368a533d8f7fb8b616c43e582
DIST aiorpcX-0.21.1.gh.tar.gz 75205 BLAKE2B 5190e8bedf9c605f57d469f351d0cc3bed0c1fad53778ea0f29c02615b0ca816a7bbc60b863dc613f72c67455966ef3ceb31b825eed3cead25f47c29012f7ce5 SHA512 c77d4bfe72f2cd4215e15330c60aabdeee9f4e1613ba5dcfedea9368c85519b36ecc7dbfa2f6682df7d802204b9cea7c9a889ee479dcffbc728ee0c112039779
DIST aiorpcX-0.22.0.gh.tar.gz 75160 BLAKE2B c9aa55c932546512019c058dd29d397bba79638a56aa949d69980abd56b4d024e9d1f99e96909c2256cce1578ffaf55b14b95d0adf77752180fcbd8ab997555b SHA512 a65202f8233adac587c98da812ab27a26740a21a68df431bf0394dc3df37f3cb15c397c6a9044201b4a1a8d6bcc283a7cf7b4dd27885a2ea0f5942cbbfc6f405
+DIST aiorpcX-0.22.1.gh.tar.gz 75206 BLAKE2B 92c481388198fec94faa10482ad4195fe6dce5ae4aa445ce2812e1e81e084c629712b87a3c157aa33ae42335c1a96bdcafa5e389802740fcae8eb9e4aaf43dd2 SHA512 3484da36ce6042d8d4c6b168fd2326c0fc77a825691b95631e54510697708a27ea07e9a808445d504056432adf04f04cb0bc28d4b7194c55c1995096bb938b4d
diff --git a/dev-python/aiorpcX/aiorpcX-0.22.1.ebuild b/dev-python/aiorpcX/aiorpcX-0.22.1.ebuild
new file mode 100644
index 000000000000..8ba0167288fa
--- /dev/null
+++ b/dev-python/aiorpcX/aiorpcX-0.22.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="https://pypi.org/project/aiorpcX/
+ https://github.com/kyuupichan/aiorpcX/"
+SRC_URI="https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # require Internet
+ tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}