summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-25 09:14:17 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-25 09:56:28 +0200
commitab04755405d9cec97ba24ddba41726ba6b8868c8 (patch)
tree07f99878f31c86a04eef4ca26fdaeb083681b9c4 /dev-python/aiorpcX
parentdev-python/xdg: Add python@ as co-maint. (diff)
downloadgentoo-ab04755405d9cec97ba24ddba41726ba6b8868c8.tar.gz
gentoo-ab04755405d9cec97ba24ddba41726ba6b8868c8.tar.bz2
gentoo-ab04755405d9cec97ba24ddba41726ba6b8868c8.zip
dev-python/aiorpcX: Bump to 0.21.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiorpcX')
-rw-r--r--dev-python/aiorpcX/Manifest1
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.21.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/aiorpcX/Manifest b/dev-python/aiorpcX/Manifest
index 8b68ce273600..39e948bce6b5 100644
--- a/dev-python/aiorpcX/Manifest
+++ b/dev-python/aiorpcX/Manifest
@@ -4,3 +4,4 @@ DIST aiorpcX-0.19.gh.tar.gz 65557 BLAKE2B 2bc9d809abbcdcf4dd0358e4bb734068ef7648
DIST aiorpcX-0.20.1.gh.tar.gz 74087 BLAKE2B eee9b3d7d1e513e5eefec97ba30b8b5783b3128cd010b6c8c9530c19c06b1261499559249a9b46c2a8689daebd78d23f97a3b16c25572de80dc13a3650d4d593 SHA512 0f03fe54f268c64028607766bd45dd2fc8ee4ddab30da7744e9493e0e98cdbd9061dd502fd1bbde1880e5f4410f147f4ecf0ea04e4056c16bb784c3f76a558fc
DIST aiorpcX-0.20.2.gh.tar.gz 74627 BLAKE2B e5a33dfd8ef0c18e26cfee881fd7515437598628bf61dfd86a34f0a758474abcf257c7afcbf0ee1d11ed6bad44596289efe2261d9ca7ccc26e7d949f05b3ad40 SHA512 af63d51bd21a045d71073ba6cd030834f8262e393eac9c44e6b33a2b3cecd86a5d2a6a0ed7ab60d2362e99ab38c801abcae1ada368a533d8f7fb8b616c43e582
DIST aiorpcX-0.21.0.gh.tar.gz 75194 BLAKE2B dc8494531ca64db15e3e4b35ef5392e8177ca9b5c885c93c146edf921154f42caef5a7b2863a166d337a2f16e99e880b1e315f1f72624f50aa2d73a93c23e054 SHA512 0bcbb31cf367db029ef4acc06b23b6d3f861ab168971e367d760a220c0a6688934a8a91f7bb2fd9d993e173f2049e45556b6f094bb7ca005b37f66179061484d
+DIST aiorpcX-0.21.1.gh.tar.gz 75205 BLAKE2B 5190e8bedf9c605f57d469f351d0cc3bed0c1fad53778ea0f29c02615b0ca816a7bbc60b863dc613f72c67455966ef3ceb31b825eed3cead25f47c29012f7ce5 SHA512 c77d4bfe72f2cd4215e15330c60aabdeee9f4e1613ba5dcfedea9368c85519b36ecc7dbfa2f6682df7d802204b9cea7c9a889ee479dcffbc728ee0c112039779
diff --git a/dev-python/aiorpcX/aiorpcX-0.21.1.ebuild b/dev-python/aiorpcX/aiorpcX-0.21.1.ebuild
new file mode 100644
index 000000000000..9d75b7b8a4da
--- /dev/null
+++ b/dev-python/aiorpcX/aiorpcX-0.21.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="https://pypi.org/project/aiorpcX/
+ https://github.com/kyuupichan/aiorpcX/"
+SRC_URI="https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # require Internet
+ tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}