summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-24 21:08:12 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-24 21:10:46 +0100
commitbac9c667a80500194ff5d81e97463f253df7c7e2 (patch)
tree87e59c832293bc6bf756f9b7abc120f7a6cf2e40 /dev-python/aiorpcX
parentapp-office/libreoffice-bin-debug: new build for new boost (diff)
downloadgentoo-bac9c667a80500194ff5d81e97463f253df7c7e2.tar.gz
gentoo-bac9c667a80500194ff5d81e97463f253df7c7e2.tar.bz2
gentoo-bac9c667a80500194ff5d81e97463f253df7c7e2.zip
dev-python/aiorpcX: Fix test failures when no resolver is available
Closes: https://bugs.gentoo.org/771645 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiorpcX')
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.18.5.ebuild12
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.19.1.ebuild10
2 files changed, 21 insertions, 1 deletions
diff --git a/dev-python/aiorpcX/aiorpcX-0.18.5.ebuild b/dev-python/aiorpcX/aiorpcX-0.18.5.ebuild
index 5daef298f5af..d5a8e748ca69 100644
--- a/dev-python/aiorpcX/aiorpcX-0.18.5.ebuild
+++ b/dev-python/aiorpcX/aiorpcX-0.18.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,3 +26,13 @@ BDEPEND="
)"
distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # require Internet
+ tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild b/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild
index 1dceb3bd58c3..94411647b986 100644
--- a/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild
+++ b/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild
@@ -26,3 +26,13 @@ BDEPEND="
)"
distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # require Internet
+ tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}