summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-12 13:58:05 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-12 13:58:27 -0600
commit03256aacb5dac32227dba0bf52867f032bf71012 (patch)
treea83f1bf645dfb8a7d77ae13fcb8e54938f924857 /dev-python/aiosmtpd
parentdev-python/atpublic: add support for python3_7 (diff)
downloadgentoo-03256aacb5dac32227dba0bf52867f032bf71012.tar.gz
gentoo-03256aacb5dac32227dba0bf52867f032bf71012.tar.bz2
gentoo-03256aacb5dac32227dba0bf52867f032bf71012.zip
dev-python/aiosmtpd: 1.2 bump with support for py37
Fixes: https://bugs.gentoo.org/691530 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/aiosmtpd')
-rw-r--r--dev-python/aiosmtpd/Manifest1
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/aiosmtpd/Manifest b/dev-python/aiosmtpd/Manifest
index 725fae4abd87..e222ac1018ef 100644
--- a/dev-python/aiosmtpd/Manifest
+++ b/dev-python/aiosmtpd/Manifest
@@ -1,2 +1,3 @@
DIST aiosmtpd-1.0.tar.gz 49930 BLAKE2B 7c8f845746b51e2b77f2ff00de2c88c3a090a4cd65e55fa69fc371f8ac5a2966c31e3e7184188a1b4af1f5c3d22b7af5655c5673d199b9920865ddf56c119a06 SHA512 874b3505dd35cbb176cba058a8816329eb4177db705b10c3883f88d76e3f587efc35543812fd36a03f453c8c1ee359bb3f0239d8a246908c5c17b59be134d933
DIST aiosmtpd-1.1.tar.gz 50722 BLAKE2B c7d21eea7816a758fb69061c0f1c4c5dbb7bd28a6daddc436211e4d8066380847255af537904ad5c09badb813269d0bc4b54dbb527b7b0c717d498c9475c8c2d SHA512 b61df616f2e14d1da67ac05149543bf48b14a31d44437d9a1dd11b166b98b56220c00e7c55e18d4fd99872d724e23f272922dd3548150632a189d9cb9b652883
+DIST aiosmtpd-1.2.tar.gz 51457 BLAKE2B c2dba38c5d5a243a65c332cb3b6bf85a124eb6ab9c3526d0ef57788eb7e24e64ec86c56eeaa57e5171631c8a965447f125366741b1d1c54fb48473da5123ed40 SHA512 520b0fae80423d3963d4f17ef393cc0ce9e342fd1237c909159706bfe1e13f27df849fbc14aa1c94ad02e7c9108308984b6f9e21c7dbddb09093ef00884983d8
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.2.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.2.ebuild
new file mode 100644
index 000000000000..c0028357df7d
--- /dev/null
+++ b/dev-python/aiosmtpd/aiosmtpd-1.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="asyncio based SMTP server"
+HOMEPAGE="https://aiosmtpd.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ rm -r examples || die
+ distutils-r1_python_prepare_all
+}