summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-08 08:18:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-08 08:25:11 +0100
commit9924e82b49a2e8ee53dd082e8cd3df024aec1b25 (patch)
treec3140e72f1cf28d5004c1221b096f837973736e3 /dev-python/aiosmtpd
parentnet-vpn/openfortivpn: Version bump 1.60.0 (diff)
downloadgentoo-9924e82b49a2e8ee53dd082e8cd3df024aec1b25.tar.gz
gentoo-9924e82b49a2e8ee53dd082e8cd3df024aec1b25.tar.bz2
gentoo-9924e82b49a2e8ee53dd082e8cd3df024aec1b25.zip
dev-python/aiosmtpd: Bump to 1.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiosmtpd')
-rw-r--r--dev-python/aiosmtpd/Manifest1
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.4.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/aiosmtpd/Manifest b/dev-python/aiosmtpd/Manifest
index cacaee26aec2..6a26ce7e06e4 100644
--- a/dev-python/aiosmtpd/Manifest
+++ b/dev-python/aiosmtpd/Manifest
@@ -4,3 +4,4 @@ DIST aiosmtpd-1.2.tar.gz 51457 BLAKE2B c2dba38c5d5a243a65c332cb3b6bf85a124eb6ab9
DIST aiosmtpd-1.3.2.tar.gz 110769 BLAKE2B 985684d8183c89670c362e39b81cbff187fa820bc3197a0c0c18cd61eb4c00912bf489d935303be0fedfee3dabfafaf81c7d4be3e428374624ed9a1fab6ce2c8 SHA512 b5d183671b8a985dcf774fb1b35ffbdf5c058e24e7cb81d77b2b0ce00b2b4dff27ff8bb167e985d5bf84cb6816c014d7cd601aab59243136ae409975ef3da30d
DIST aiosmtpd-1.4.0.tar.gz 136307 BLAKE2B 5ae007be6953de8fd804bef25e290153ead6730bf44dbf71448946c1380a972a59b0fcf6f669035dd23acc582d697dc746efe0b03612e6c3ee51b31d58aee309 SHA512 cefbc819a51cbdacc8f24d0f5ff4f2a92ad6e4c5809a9b97635226767f1dd20c63565522ab66fd6c7ede5efdafa89c42e3c3bae4e94ea5c57b49531b02e1bad6
DIST aiosmtpd-1.4.1.tar.gz 137171 BLAKE2B 601cbcc1eb409277dfada35bd8bf39c7282651b479a4db4a7716ef74dd66fce37bdeb7b0fd8fceb9889ec247e1ec32d9b2305de74868feceba208c23835e08de SHA512 f018e0a75adaa269c1f003a6f7fbbe92257c518ea9b62ffd807bb75a169362ff1159b69562b0d6cfa211ff5cd19f0756ed78c92a7be533a0c1929608d6eacc82
+DIST aiosmtpd-1.4.2.tar.gz 140630 BLAKE2B 9a725d3aa28943afbb14fb6792e0115cf4bc257250da815183c9c9e6b293cf71ac836cc811f50e48bc450d3f629f74d1948aaef78d44852bc96fb3daf0398605 SHA512 b910ae4c00b52f59b9f2199b296a1b76caa7567cbcd2e27c73d4ec894e9b48cd8190090083ce33b87dc924c4394a6425506355951208af65b89a6c1abe371114
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.4.2.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.4.2.ebuild
new file mode 100644
index 000000000000..3c32f8604a09
--- /dev/null
+++ b/dev-python/aiosmtpd/aiosmtpd-1.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="asyncio based SMTP server"
+HOMEPAGE="https://aiosmtpd.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' python3_7)"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+# TODO: run doctests using sphinx?
+distutils_enable_tests pytest