summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-21 09:07:54 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-21 09:23:15 +0100
commit7852f514b110c3d0ac5e5191a8401d6d9fec9c7e (patch)
tree99ba10491a8ef3fa51d91a49d75298d9e2c08c9c /dev-python/alembic
parentdev-python/pyperclip: Bump to 1.8.2 (diff)
downloadgentoo-7852f514b110c3d0ac5e5191a8401d6d9fec9c7e.tar.gz
gentoo-7852f514b110c3d0ac5e5191a8401d6d9fec9c7e.tar.bz2
gentoo-7852f514b110c3d0ac5e5191a8401d6d9fec9c7e.zip
dev-python/alembic: Bump to 1.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.5.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index 3a6d44a9223a..16236e5b10e2 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1,2 +1,3 @@
DIST alembic-1.5.1.tar.gz 1128404 BLAKE2B 70a2ce16adcf317c9376f77d8fa88e9eef3aa4090de5f933187f47df9fe6ac40a25df75d6c74c50c3be23dd3cef13d465eb2ddae4ea83558d01ebffd8effe241 SHA512 2fe490c46c253123333f0496fe28b59956efc78924f145b69ba95e5cb1cc091a72047c1aa5f8a85924ec59ad0aba2bfa143b9cad475dedc6f849c38695c08601
DIST alembic-1.5.4.tar.gz 1133598 BLAKE2B 88e1f40ef1935b90de789f1adc99edb5fc580c96a3e86a672cc9cfd694e79e940ba696efe560db3bf2878420a168382ed4342cbf1b8c7b9bbbf084532b8da402 SHA512 190f8fe96f18541fd62802e026e93c332f6046618cb89d4f9a6b478505742671d363de1161feeccd8873036a458743165080b5a0e2e55e1d0dd81e617c8cd4ad
+DIST alembic-1.5.5.tar.gz 1150308 BLAKE2B 33db8a0ea00802b37d3e24ca43232a993bfc333e232fa08b8dd0560dfec5f18f4fa82bcc3c34a776c88c8fc8d3645c4501a9dde8e4e5411bc255eb654183d01a SHA512 a4078c66bbe1627620224f965b879c46453bc74e6a2a902619df28912f55b27f086cba68f08bc8c0a37bd221ac16e195f7f905379fd5d191854adb7f90f86530
diff --git a/dev-python/alembic/alembic-1.5.5.ebuild b/dev-python/alembic/alembic-1.5.5.ebuild
new file mode 100644
index 000000000000..32d428a7bdf3
--- /dev/null
+++ b/dev-python/alembic/alembic-1.5.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://github.com/sqlalchemy/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}