summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-05 10:08:49 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-05 11:19:07 +0200
commit37e723a40bbc8e99ccfca71c62c7a86542186c56 (patch)
tree327435508f53e8e86c35fb77c14f82ea0eb204c5 /dev-python/algopy/algopy-0.5.3.ebuild
parentdev-cpp/threadpool: Remove deprecated ebuild (diff)
downloadgentoo-37e723a40bbc8e99ccfca71c62c7a86542186c56.tar.gz
gentoo-37e723a40bbc8e99ccfca71c62c7a86542186c56.tar.bz2
gentoo-37e723a40bbc8e99ccfca71c62c7a86542186c56.zip
dev-python/algopy: Add py3.5 support
* EAPI=6 * Fix one error in testsuite by backporting upstream fix https://github.com/b45ch1/algopy/commit/f563d86e72b32caa296ac77b0836ce0e36a5f6ab Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/algopy/algopy-0.5.3.ebuild')
-rw-r--r--dev-python/algopy/algopy-0.5.3.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/algopy/algopy-0.5.3.ebuild b/dev-python/algopy/algopy-0.5.3.ebuild
index 900facfc5559..3597aa272ca8 100644
--- a/dev-python/algopy/algopy-0.5.3.ebuild
+++ b/dev-python/algopy/algopy-0.5.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
@@ -24,6 +24,7 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )
"
+PATCHES=( "${FILESDIR}/${P}-fix-test-cast-ufunc.patch" )
python_test() {
${EPYTHON} run_tests.py || die