summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-26 07:45:06 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-26 08:10:11 +0100
commit2fed6438c37a436822e8f9d95dde8148d582a955 (patch)
tree16387f4c8f36bd0592e08be54a773286b487eb00 /dev-python/amodem
parentdev-python/tox: Bump to 4.0.17 (diff)
downloadgentoo-2fed6438c37a436822e8f9d95dde8148d582a955.tar.gz
gentoo-2fed6438c37a436822e8f9d95dde8148d582a955.tar.bz2
gentoo-2fed6438c37a436822e8f9d95dde8148d582a955.zip
dev-python/amodem: Bump to 1.15.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/amodem')
-rw-r--r--dev-python/amodem/Manifest1
-rw-r--r--dev-python/amodem/amodem-1.15.4.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/amodem/Manifest b/dev-python/amodem/Manifest
index 7d8633d17572..e1974d5fd355 100644
--- a/dev-python/amodem/Manifest
+++ b/dev-python/amodem/Manifest
@@ -1 +1,2 @@
DIST amodem-1.15.3.tar.gz 30297 BLAKE2B 7ab9bce50eee0fbd788fc42ca668a187ac14e5c8e9c6d2a8c4fcddf24ec77a5e40c37edf21222d49f984d343adf46ad710973dc689e18e9065b470b4d1e3a5b6 SHA512 72e574bc4ddfbe949763427587ed2afe8baf153188cb2c6abda1c9f0e9e8f483bdda1edff9278519130b1b5d5487527d83cc9307e6f47a7a86404757199e0712
+DIST amodem-1.15.4.tar.gz 30661 BLAKE2B eea709db3be5a04c569de85457500d390432d78d6cdfab44780a7be9c885538715157cf5cd94c27a5d4e706d6f23f41dc6f863a72ccf8366de08956c2e50cbff SHA512 19eb8ed24ee93652b911a3a8b10fc89b7d567d8302328d93255d65d82c29c50d06855ba6e4228b2f12d50e7dcaadd4539305a34321a7e96ba87b2da9e25a3391
diff --git a/dev-python/amodem/amodem-1.15.4.ebuild b/dev-python/amodem/amodem-1.15.4.ebuild
new file mode 100644
index 000000000000..23b64e180f5b
--- /dev/null
+++ b/dev-python/amodem/amodem-1.15.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Transmit data between two computers using audio"
+HOMEPAGE="
+ https://github.com/romanz/amodem/
+ https://pypi.org/project/amodem/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest