summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-19 01:04:53 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-19 01:11:57 +0100
commitc97383d847e99bbc15fb9c7a43757d9224d8c2c4 (patch)
tree65ac5bc07691e51c0f31663c741d2e897521bae6 /dev-python/aniso8601
parentsys-apps/pkgcore: Bump to 0.11.3 (diff)
downloadgentoo-c97383d847e99bbc15fb9c7a43757d9224d8c2c4.tar.gz
gentoo-c97383d847e99bbc15fb9c7a43757d9224d8c2c4.tar.bz2
gentoo-c97383d847e99bbc15fb9c7a43757d9224d8c2c4.zip
dev-python/aniso8601: Bump to 9.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aniso8601')
-rw-r--r--dev-python/aniso8601/Manifest1
-rw-r--r--dev-python/aniso8601/aniso8601-9.0.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/aniso8601/Manifest b/dev-python/aniso8601/Manifest
index 883a1eded4a9..80699db7574f 100644
--- a/dev-python/aniso8601/Manifest
+++ b/dev-python/aniso8601/Manifest
@@ -1,2 +1,3 @@
DIST aniso8601-8.0.0.tar.gz 37007 BLAKE2B bb5f42928308fab7746cbea364c03db4813b1b25883495d0488eb755e14f465300662b07c4ccfd03328a0c0f07ed87056ccc13f2652648c4838b0433740fc3ab SHA512 1e6c43f77993e829833d819f7c2b9b1d31f30ca46e258faac0e0b3be864da07436ae34f05710309302477bb3eede5966c95ef3b124c9b353b306c2272dc4cb9d
DIST aniso8601-8.1.1.tar.gz 39143 BLAKE2B d72161923e164032e1b9e4ed317d688d70b2a16bec6c23966f76abbb4d10f24def18df41fcca4e8f45e6145f4f067ec5483f34305a33eee3445d4706df188a99 SHA512 f9c3412c5e7dec04cca56df5806a747779848adb90137293368b4d50c365692b1d1f792a00f57172925229ccdee34ef5b50cc2d06f4c9b4d697c651e5a2e3674
+DIST aniso8601-9.0.0.tar.gz 46924 BLAKE2B 2dc0d24b536de48b3c1367203d685b00fcde8b257fc407ad38461422d4b278af1f29bd32dd74136c72204530d874d427d967f711aa69c9224c47ea3883a70102 SHA512 e0fc9ab1de36ddc7a78c0fdd139769312302bb2f8d7ce874aba1e714c7da25ed153a883ef92e62ad9f1a0c4d192c43cc939b8e82405f9f60b7d4b400f104e348
diff --git a/dev-python/aniso8601/aniso8601-9.0.0.ebuild b/dev-python/aniso8601/aniso8601-9.0.0.ebuild
new file mode 100644
index 000000000000..298eb44a792c
--- /dev/null
+++ b/dev-python/aniso8601/aniso8601-9.0.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for parsing ISO 8601 strings"
+HOMEPAGE="https://bitbucket.org/nielsenb/aniso8601/ https://pypi.org/project/aniso8601/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=">=dev-python/python-dateutil-2.7.3[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest