summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-08 20:28:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-08 21:14:29 +0100
commitaa0ea09559a0bbeb613a7db64f92764d8cc0be33 (patch)
tree4c6ab70e4b308cebfe70d0d956e66c9cea576257 /dev-python/ansi
parentsci-mathematics/cvc4: fix library path (diff)
downloadgentoo-aa0ea09559a0bbeb613a7db64f92764d8cc0be33.tar.gz
gentoo-aa0ea09559a0bbeb613a7db64f92764d8cc0be33.tar.bz2
gentoo-aa0ea09559a0bbeb613a7db64f92764d8cc0be33.zip
dev-python/ansi: Bump to 0.3.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ansi')
-rw-r--r--dev-python/ansi/Manifest1
-rw-r--r--dev-python/ansi/ansi-0.3.6.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/ansi/Manifest b/dev-python/ansi/Manifest
index b45fe7261f74..4b5fb73d3a39 100644
--- a/dev-python/ansi/Manifest
+++ b/dev-python/ansi/Manifest
@@ -1,2 +1,3 @@
DIST ansi-0.2.0.tar.gz 5173 BLAKE2B 436caa8e1f36e96f1844e79e3a0ff0c4099e76b25ce9f56c9d8663aeeb650f32fba75a14fe8548f557fb020e2340707272fdda4cdd3c245c903a4f801ae48413 SHA512 22c69b5030f03eca9470e288c16e62042ccd02ef2e232600a4fab629354601d5da0f7c16b60dae7293c69255e5d4125298890d99dba8e5387960a5be60b92d61
DIST ansi-0.3.5.tar.gz 6597 BLAKE2B 4e32bd7add4af1d9f11173aa79d6ed139814f3b3727a4599f104e8632a4e169fdaccf3e18ecf425f86c17c70c1d185f6a915bd9cbac2589d376fc23c338127e6 SHA512 a12b7e1231c2691edf6d807907fe6b8a8d6c6bc116fd9681b6bb7603e6e2ce7af17e3e7892d4046752844327eb8f02a248f93686640bec24dbe2be59202b01e3
+DIST ansi-0.3.6.tar.gz 6668 BLAKE2B a2bd492aa5c68041feeb04e798ce301ae50ba217c695f4500b033911a719a9e91dc6213d81361e36819a1d46ddeef82e4684ee0c395ec70fc93c6957e2a410b2 SHA512 6b7512013db18436f5982175d82c9f333eef7655eece12454f4731c7f2ed675ab39986e813560d1621b365b7541a5ca6c37d88f2ca5be4460f1ae86cb27d1911
diff --git a/dev-python/ansi/ansi-0.3.6.ebuild b/dev-python/ansi/ansi-0.3.6.ebuild
new file mode 100644
index 000000000000..838f9f8f9f2e
--- /dev/null
+++ b/dev-python/ansi/ansi-0.3.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI cursor movement and graphics in Python"
+HOMEPAGE="https://github.com/tehmaze/ansi/"
+SRC_URI="https://github.com/tehmaze/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest