summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-10 10:40:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-10 12:06:47 +0200
commit6204207ab1bd1c3515beb96852f539cb4ca437a2 (patch)
tree880ea595b64773e55093d6cad7c4927c15b6a24c /dev-python/ansible-compat
parentdev-python/python-nbxmpp: Bump to 3.0.1 (diff)
downloadgentoo-6204207ab1bd1c3515beb96852f539cb4ca437a2.tar.gz
gentoo-6204207ab1bd1c3515beb96852f539cb4ca437a2.tar.bz2
gentoo-6204207ab1bd1c3515beb96852f539cb4ca437a2.zip
dev-python/ansible-compat: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-2.0.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 7c4e709427c7..fe1285517014 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1 +1,2 @@
DIST ansible-compat-2.0.2.tar.gz 35072 BLAKE2B 288baaa4bb535da5fc41ea6a700d4eaf969b466848a592f3c919cac55b237cc81b9bfcd800a429b89c82781b29e80dc6486ea9bf0621ae8a3f249139021030e2 SHA512 ae278498f58ac1eb663115215e7ef6bda7279ff02d4a1f09e8301b88681d8c46f13a620b765cbbbacfc3d1fe8b294d5258cddbf7fd2f2cb54f0bde85fc9af593
+DIST ansible-compat-2.0.3.tar.gz 35328 BLAKE2B cd5a476eb23de667381c9a6667d6bd781821fc50e1aec65ca47e8bb9d47beccbea0ee62f763ed421c18c95d9f1d1c14f5cc2a62bcc77d664213eb614ccd568e4 SHA512 0887e5da23041d02be0371bfd9569256252c586f80cd92ab855b32172328989c8160e57169aff6d72f1c3c89c9d3a00b56293e3badc0dc4aad135b1992d06599
diff --git a/dev-python/ansible-compat/ansible-compat-2.0.3.ebuild b/dev-python/ansible-compat/ansible-compat-2.0.3.ebuild
new file mode 100644
index 000000000000..963815e41a06
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-2.0.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-base-2.9.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-markdown[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_sphinx docs \
+ dev-python/ansible-pygments \
+ dev-python/myst_parser \
+ dev-python/sphinx_ansible_theme
+
+distutils_enable_tests pytest