summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-18 09:52:43 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-18 11:08:26 +0100
commitbf241e90de8507db676ade576b00fee5a1b5c56c (patch)
treedf1140a749e65d1f76ffe937a5237ef4419963ff /dev-python/ansible-compat
parentdev-python/pyfakefs: Bump to 4.5.6 (diff)
downloadgentoo-bf241e90de8507db676ade576b00fee5a1b5c56c.tar.gz
gentoo-bf241e90de8507db676ade576b00fee5a1b5c56c.tar.bz2
gentoo-bf241e90de8507db676ade576b00fee5a1b5c56c.zip
dev-python/ansible-compat: Bump to 2.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-2.0.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 1acf1b8455fd..7eb24cc9e36e 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,2 +1,3 @@
DIST ansible-compat-1.0.0.tar.gz 34729 BLAKE2B 56eb32314e310777e454a5f5e020cc4dfc485e6d5720d45e99734ce8cf238377f1ff443f9f78f5b9de947944564a7001294907c0e186fe94cd4561d4d348723e SHA512 dd02b47acf38b378016acbe6f2e6494df1cbf68d88a0cb685a5f594ee24b23af1c4d14878090ba7ea69f76185afb57eeb546cc40a6038171eebc991401c6e241
DIST ansible-compat-2.0.0.tar.gz 34702 BLAKE2B a88afd442ffa520037957a537be5a22c8644c1a3d3cc9e23645f74687db068113945869c271b93ad1fdc07ebc58f29d3137e606889a0eb01ad0e68f75237ba1f SHA512 2b2aade5a201e6edbd5000b0e19497eb5ed5eaf9633edd502c19596b3d1018212f5504f1abad5bc225a8128ad5bb118fcea664b3a927490bcb3636e00ec16fd9
+DIST ansible-compat-2.0.2.tar.gz 35072 BLAKE2B 288baaa4bb535da5fc41ea6a700d4eaf969b466848a592f3c919cac55b237cc81b9bfcd800a429b89c82781b29e80dc6486ea9bf0621ae8a3f249139021030e2 SHA512 ae278498f58ac1eb663115215e7ef6bda7279ff02d4a1f09e8301b88681d8c46f13a620b765cbbbacfc3d1fe8b294d5258cddbf7fd2f2cb54f0bde85fc9af593
diff --git a/dev-python/ansible-compat/ansible-compat-2.0.2.ebuild b/dev-python/ansible-compat/ansible-compat-2.0.2.ebuild
new file mode 100644
index 000000000000..5002b5d41ebc
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-2.0.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="https://pypi.org/project/ansible-compat/ https://github.com/ansible-community/ansible-compat/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=app-admin/ansible-base-2.9.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-markdown[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_sphinx docs \
+ dev-python/ansible-pygments \
+ dev-python/myst_parser \
+ dev-python/sphinx_ansible_theme
+
+distutils_enable_tests pytest