summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-19 19:12:07 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-19 19:24:06 +0100
commitd7774f16018d6454e5861059efe966041a369613 (patch)
tree7df4680fb668d3f3cfef203146e57bc06f0f8f56 /dev-python/ansible-compat
parentnet-firewall/nftables: Version bump to 1.0.1, sync 9999 (diff)
downloadgentoo-d7774f16018d6454e5861059efe966041a369613.tar.gz
gentoo-d7774f16018d6454e5861059efe966041a369613.tar.bz2
gentoo-d7774f16018d6454e5861059efe966041a369613.zip
dev-python/ansible-compat: deselect network sandbox-violating tests
All of these tests fail if the network sandbox is active because they try to connect to the Ansible Galaxy API server. One of these days I *will* remember that our network sandbox does not work in Docker. Closes: https://bugs.gentoo.org/824950 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/ansible-compat-0.5.0.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/ansible-compat-0.5.0.ebuild b/dev-python/ansible-compat/ansible-compat-0.5.0.ebuild
index 4001784180fa..7b7537c2f7bc 100644
--- a/dev-python/ansible-compat/ansible-compat-0.5.0.ebuild
+++ b/dev-python/ansible-compat/ansible-compat-0.5.0.ebuild
@@ -33,6 +33,20 @@ BDEPEND="$(python_gen_cond_dep '
)
')"
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
# Requires currently unpackaged Sphinx extension myst_parser
#distutils_enable_sphinx docs 'dev-python/sphinx_ansible_theme'