summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-29 23:44:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-29 23:49:09 +0200
commit781ccfea930c7100ef1908f954e84d166ede0dc0 (patch)
treece5318633deb168aaae3f3fdb5b453e4ee148388 /dev-python/argon2-cffi
parentdev-python/zeroconf: Remove old (diff)
downloadgentoo-781ccfea930c7100ef1908f954e84d166ede0dc0.tar.gz
gentoo-781ccfea930c7100ef1908f954e84d166ede0dc0.tar.bz2
gentoo-781ccfea930c7100ef1908f954e84d166ede0dc0.zip
dev-python/argon2-cffi: Bump to 21.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argon2-cffi')
-rw-r--r--dev-python/argon2-cffi/Manifest1
-rw-r--r--dev-python/argon2-cffi/argon2-cffi-21.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/argon2-cffi/Manifest b/dev-python/argon2-cffi/Manifest
index f2c4dea9eb21..000c51bb9b63 100644
--- a/dev-python/argon2-cffi/Manifest
+++ b/dev-python/argon2-cffi/Manifest
@@ -1 +1,2 @@
DIST argon2-cffi-20.1.0.tar.gz 1814415 BLAKE2B c216349beffa263fd96df23f40a8102b56a88b8320e64ac062ecfea4582efa34b298ba223437bfbfc422b68a3d9b9ea769c384db078c633103f2aae3cd38bd5b SHA512 d1d798e3e51ed67c4f523a66081fea99479ee986b5cfc36b250954e757b9846625681445447f9347519d9988f8a2ace2e3c8ce5817c5c6b4767819cf56ee0af2
+DIST argon2-cffi-21.1.0.tar.gz 1807800 BLAKE2B 47b1e785b7eb173b671a44e9212af76a59f453c3c0d0e5f2c437e7a62132abf86ab6baa8bdd656ad28d00a151296a66211d365c0afe228821c8c1ff1a0a66c46 SHA512 bbfebd2c075f360a6c1c187c0789be2aae7480b9398f36db7bdfe74f288d9e00b44a788918c54f4cc8bb1947136ab0493f61975de408c482a5131e2bf1a8f4d0
diff --git a/dev-python/argon2-cffi/argon2-cffi-21.1.0.ebuild b/dev-python/argon2-cffi/argon2-cffi-21.1.0.ebuild
new file mode 100644
index 000000000000..3adfb492ab84
--- /dev/null
+++ b/dev-python/argon2-cffi/argon2-cffi-21.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="CFFI bindings to the Argon2 password hashing library"
+HOMEPAGE="https://github.com/hynek/argon2-cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ app-crypt/argon2:=
+ virtual/python-cffi[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst FAQ.rst README.rst )
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+export ARGON2_CFFI_USE_SYSTEM=1