summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-22 20:17:22 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-22 20:25:17 +0200
commit5c5fcd426107dbfd569e8891a0e4ce678e0e69f2 (patch)
tree09423e23d28d5825bae4e52d024b969aead570ef /dev-python/asgiref
parentgnome-base/dconf-editor: fix build with meson-0.61 (diff)
downloadgentoo-5c5fcd426107dbfd569e8891a0e4ce678e0e69f2.tar.gz
gentoo-5c5fcd426107dbfd569e8891a0e4ce678e0e69f2.tar.bz2
gentoo-5c5fcd426107dbfd569e8891a0e4ce678e0e69f2.zip
dev-python/asgiref: add 3.5.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/asgiref')
-rw-r--r--dev-python/asgiref/Manifest1
-rw-r--r--dev-python/asgiref/asgiref-3.5.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/asgiref/Manifest b/dev-python/asgiref/Manifest
index a97fd0db9b55..74a1de0fdde1 100644
--- a/dev-python/asgiref/Manifest
+++ b/dev-python/asgiref/Manifest
@@ -1 +1,2 @@
DIST asgiref-3.4.1.tar.gz 32529 BLAKE2B 4b5f3b33e165468d71711cf28a5a6161866cd7495140cb67ff028aba5a2586414783d2fa7ce744e99e269714d9d64a019a67c852fd4546ba1f71625473010b9f SHA512 af266fc3eac58c21f2ab3f66e522067388f9cf232b17344fb5afbc408c034e61a1cce02362ec5dc494985beef099800f75cf7de28dc057c45e4bcb973b0a6dbe
+DIST asgiref-3.5.0.tar.gz 31920 BLAKE2B 3471e799da0ba5cd8640612d0ff04e480d6c431a44c1e94419cdfc3a029c83ffe53aa561952fcf9c0df4a5ec71282afd8f4c665b49c408306f8f7026e0a0023c SHA512 3fa48002bffd953f3ff8bc33e5604955ee83fbfc09cae171b95d57773378ada554342f2af58a4a04025a070cd2ec5a6b1bd5a8b18a5c5b87b2b510bbb2036e57
diff --git a/dev-python/asgiref/asgiref-3.5.0.ebuild b/dev-python/asgiref/asgiref-3.5.0.ebuild
new file mode 100644
index 000000000000..6d47406d260b
--- /dev/null
+++ b/dev-python/asgiref/asgiref-3.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="ASGI utilities (successor to WSGI)"
+HOMEPAGE="
+ https://asgi.readthedocs.io/en/latest/
+ https://github.com/django/asgiref/
+ https://pypi.org/project/asgiref/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? ( dev-python/pytest-asyncio[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest