summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-12 20:50:20 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-12 20:50:20 +0200
commitbc0500ae7beeee6f2c6ceeff927b334572890e2a (patch)
treee9e5582dad30db19277093a4bdaf8685c9dd05dd /dev-python/astroid/astroid-1.4.6.ebuild
parentdev-python/pylint: Bump (diff)
downloadgentoo-bc0500ae7beeee6f2c6ceeff927b334572890e2a.tar.gz
gentoo-bc0500ae7beeee6f2c6ceeff927b334572890e2a.tar.bz2
gentoo-bc0500ae7beeee6f2c6ceeff927b334572890e2a.zip
dev-python/astroid: Bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/astroid/astroid-1.4.6.ebuild')
-rw-r--r--dev-python/astroid/astroid-1.4.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/astroid/astroid-1.4.6.ebuild b/dev-python/astroid/astroid-1.4.6.ebuild
new file mode 100644
index 000000000000..6b8d7cadb2ec
--- /dev/null
+++ b/dev-python/astroid/astroid-1.4.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="https://bitbucket.org/logilab/astroid https://pypi.python.org/pypi/astroid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="test"
+
+# still broken
+RESTRICT=test
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]"
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? (
+# ${RDEPEND}
+# >=dev-python/pylint-1.4.0[${PYTHON_USEDEP}]
+# dev-python/pytest[${PYTHON_USEDEP}]
+# $(python_gen_cond_dep 'dev-python/egenix-mx-base[${PYTHON_USEDEP}]' python2_7)
+# )"
+# Required for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ ${EPYTHON} -m unittest discover -p "unittest*.py" --verbose || die
+}