summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-03-09 18:45:48 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-03-09 18:47:18 +0000
commit60989f92574446adc0fbac647734f547c1a3da09 (patch)
tree31681c266ca187c6a9ec65f984a9e710388c3e7d /dev-python/astroml-addons
parentdev-python/astroquery: initial import (diff)
downloadgentoo-60989f92574446adc0fbac647734f547c1a3da09.tar.gz
gentoo-60989f92574446adc0fbac647734f547c1a3da09.tar.bz2
gentoo-60989f92574446adc0fbac647734f547c1a3da09.zip
dev-python/astroml-addons: initial import
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/astroml-addons')
-rw-r--r--dev-python/astroml-addons/Manifest1
-rw-r--r--dev-python/astroml-addons/astroml-addons-0.2.2.ebuild29
-rw-r--r--dev-python/astroml-addons/metadata.xml22
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/astroml-addons/Manifest b/dev-python/astroml-addons/Manifest
new file mode 100644
index 000000000000..0e5b4b6894fb
--- /dev/null
+++ b/dev-python/astroml-addons/Manifest
@@ -0,0 +1 @@
+DIST astroML_addons-0.2.2.tar.gz 51052 SHA256 c4b6e9d9f86550e1a59b54ddedf6666c7293bd7ad7b99549170e3053e57cb0cb SHA512 97c61c731d3dd8cadbfcb36defd1a678f776a2012fda1159621d3e364e25ca74cd0d284980f52095a2df31973cefba09f9b3efe72ba95b4f65ca13e4aaec5e20 WHIRLPOOL d8c7650692cbbb90f4f820804603dfdc87f5bb063ff0a1977f51c0f4c40313c4a98c50385027e35ce01ed9f02b59cc009f081c8da168397f2bb141c4f867262c
diff --git a/dev-python/astroml-addons/astroml-addons-0.2.2.ebuild b/dev-python/astroml-addons/astroml-addons-0.2.2.ebuild
new file mode 100644
index 000000000000..9d8de51c2ad2
--- /dev/null
+++ b/dev-python/astroml-addons/astroml-addons-0.2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MYPN=astroML_addons
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Performance add-ons for the astroML package"
+HOMEPAGE="https://github.com/astroML/astroML_addons"
+SRC_URI="mirror://pypi/${PN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/astroml[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MYP}"
+
+DOCS=( README.rst )
diff --git a/dev-python/astroml-addons/metadata.xml b/dev-python/astroml-addons/metadata.xml
new file mode 100644
index 000000000000..ebd85e9ae570
--- /dev/null
+++ b/dev-python/astroml-addons/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ astroML is split into two components. The core astroML library is written
+ in python only, and is designed to be very easy to install for any users,
+ even those who don't have a working C or fortran compiler. A companion library,
+ astroML_addons, can be optionally installed for increased performance on
+ certain algorithms. Every algorithm in astroML_addons has a pure python
+ counterpart in the core astroML implementation, but the astroML_addons library
+ contains faster and more efficient implementations in compiled code.
+ Furthermore, if astroML_addons is installed on your system, the core astroML
+ library will import and use the faster routines by default.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">astroML_addons</remote-id>
+ </upstream>
+</pkgmetadata>