summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/astropy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/astropy')
-rw-r--r--dev-python/astropy/Manifest4
-rw-r--r--dev-python/astropy/astropy-0.3.1.ebuild65
-rw-r--r--dev-python/astropy/astropy-0.3.2.ebuild65
-rw-r--r--dev-python/astropy/astropy-0.4.4.ebuild70
-rw-r--r--dev-python/astropy/astropy-0.4.ebuild70
-rw-r--r--dev-python/astropy/metadata.xml13
6 files changed, 287 insertions, 0 deletions
diff --git a/dev-python/astropy/Manifest b/dev-python/astropy/Manifest
new file mode 100644
index 000000000000..0f13e61473f5
--- /dev/null
+++ b/dev-python/astropy/Manifest
@@ -0,0 +1,4 @@
+DIST astropy-0.3.1.tar.gz 6190259 SHA256 e296b445943c842adc18db2dcbfe6fb1b79d4b95cae0f5bac768fd78f4af30ac SHA512 f2beacbc49e8d8af93b0fdbc5e6def7de7e854592d73bf84b14e8571cf7688d46c6b62f014be38e793c899c94b5803bf63f695723777dc74fef1da63bd8e14d4 WHIRLPOOL 46e377c57536a8a945d212a40179391d4362dc2641ae9ba84e36dbf47a0e4ed4b3a86745a68fb25318a0e1076ba5df719ecf95150f500c2f252cb8d349bb98bf
+DIST astropy-0.3.2.tar.gz 6375740 SHA256 0b564870f5c198885d9bbb1b3d07e526439303f37c2c654a879d1f9dee270915 SHA512 f3ec641a6ef31668fbbe4aac6517a442bfca006b4d58a3240aef06833c74c59abdb586658d057ecd1defc616a90e0b82d3e66de26f8d76d945238d443bf82267 WHIRLPOOL 551d0cae993e5d494cd4c157c76f8f7352548a0d575533105b5bdff12ac925e3b51c15a704342298292d07f70295a90800af99176591de0297e70c555b38881a
+DIST astropy-0.4.4.tar.gz 6939433 SHA256 8b2bc2a82b8de48e5ee247c52f20e6d9c32a801e338b3086e9cd39b5219e3389 SHA512 235cd2a9a48276872fd7bcdfe11a74809fef042b9e2caf9d493c804ac48340793fc1ba542327c2e10a94ac569365d6421544bcc7b7a842b50b638f4abc6ae0b0 WHIRLPOOL b947dbe718f02edd773e32a7922b67d7fba2d74ee06bc262defb5616f9cee5354105a3d5076e0e138cc0faa1fac65256550a63506e2fbb1e5f92a4326be0700f
+DIST astropy-0.4.tar.gz 6906375 SHA256 bcb16f7e01d74851d43c13a372fd5e240014ae9bc695a87ed2e2693d36581aba SHA512 661c9a5ea01aa5b38737606df5fdceb1e59cd63d669db01cb18dc20939301b058f5a1696725f25a21f87798fd2457bc96e726c4b52f5bf2473236c0e423e8047 WHIRLPOOL 951af517a3d5612be9ed1a23684a48e750521723fb5b982947e0c08a0f80fc53a1adce36d055b47f1374ec28028d08d47a0258570c1b4075448a72f95a2d588a
diff --git a/dev-python/astropy/astropy-0.3.1.ebuild b/dev-python/astropy/astropy-0.3.1.ebuild
new file mode 100644
index 000000000000..97a51569472d
--- /dev/null
+++ b/dev-python/astropy/astropy-0.3.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core functionality for performing astrophysics with Python"
+HOMEPAGE="http://astropy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-libs/expat:0=
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-astronomy/erfa:0=
+ sci-astronomy/wcslib:0=
+ >=sci-libs/cfitsio-3.350:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/matplotlib
+ dev-python/sphinx
+ media-gfx/graphviz
+ )
+ test? (
+ dev-libs/libxml2
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )"
+
+python_compile() {
+ distutils-r1_python_compile --use-system-libraries
+}
+
+python_compile_all() {
+ if use doc; then
+ python_export_best
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/astropy/astropy-0.3.2.ebuild b/dev-python/astropy/astropy-0.3.2.ebuild
new file mode 100644
index 000000000000..50f2cbdc1935
--- /dev/null
+++ b/dev-python/astropy/astropy-0.3.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core functionality for performing astrophysics with Python"
+HOMEPAGE="http://astropy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-libs/expat:0=
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-astronomy/erfa:0=
+ sci-astronomy/wcslib:0=
+ >=sci-libs/cfitsio-3.350:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+ test? (
+ dev-libs/libxml2
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )"
+
+python_compile() {
+ distutils-r1_python_compile --use-system-libraries
+}
+
+python_compile_all() {
+ if use doc; then
+ python_export_best
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/astropy/astropy-0.4.4.ebuild b/dev-python/astropy/astropy-0.4.4.ebuild
new file mode 100644
index 000000000000..70950a2bd53d
--- /dev/null
+++ b/dev-python/astropy/astropy-0.4.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core functionality for performing astrophysics with Python"
+HOMEPAGE="http://astropy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-libs/expat:0=
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-astronomy/erfa:0=
+ >=sci-astronomy/wcslib-4.23:0=
+ >=sci-libs/cfitsio-3.350:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+ test? (
+ dev-libs/libxml2[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )"
+
+python_compile() {
+ distutils-r1_python_compile --use-system-libraries --offline
+}
+
+python_compile_all() {
+ if use doc; then
+ python_export_best
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --offline
+ fi
+}
+
+python_test() {
+ esetup.py --offline test
+}
+
+python_install() {
+ distutils-r1_python_install --offline
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all --offline
+}
diff --git a/dev-python/astropy/astropy-0.4.ebuild b/dev-python/astropy/astropy-0.4.ebuild
new file mode 100644
index 000000000000..70950a2bd53d
--- /dev/null
+++ b/dev-python/astropy/astropy-0.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core functionality for performing astrophysics with Python"
+HOMEPAGE="http://astropy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-libs/expat:0=
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-astronomy/erfa:0=
+ >=sci-astronomy/wcslib-4.23:0=
+ >=sci-libs/cfitsio-3.350:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+ test? (
+ dev-libs/libxml2[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )"
+
+python_compile() {
+ distutils-r1_python_compile --use-system-libraries --offline
+}
+
+python_compile_all() {
+ if use doc; then
+ python_export_best
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --offline
+ fi
+}
+
+python_test() {
+ esetup.py --offline test
+}
+
+python_install() {
+ distutils-r1_python_install --offline
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all --offline
+}
diff --git a/dev-python/astropy/metadata.xml b/dev-python/astropy/metadata.xml
new file mode 100644
index 000000000000..5dab9c71475d
--- /dev/null
+++ b/dev-python/astropy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-astronomy</herd>
+ <longdescription lang="en">
+ Astropy is a community-driven package intended to contain much of
+ the core functionality and some common tools needed for performing
+ astronomy and astrophysics with Python.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">astropy</remote-id>
+ </upstream>
+</pkgmetadata>