summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-11 11:19:36 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-11 11:59:05 +0200
commitaa3b864e0ab8b7df5acce23249dee04f78e4114f (patch)
tree5e1c940d0cd552ab9f16dbae1520a2f0eaaef347 /dev-python/asttokens
parentdev-python/setuptools-rust: Bump to 1.5.0 (diff)
downloadgentoo-aa3b864e0ab8b7df5acce23249dee04f78e4114f.tar.gz
gentoo-aa3b864e0ab8b7df5acce23249dee04f78e4114f.tar.bz2
gentoo-aa3b864e0ab8b7df5acce23249dee04f78e4114f.zip
dev-python/asttokens: Bump to 2.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asttokens')
-rw-r--r--dev-python/asttokens/Manifest1
-rw-r--r--dev-python/asttokens/asttokens-2.0.7.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/asttokens/Manifest b/dev-python/asttokens/Manifest
index 09dd9550f1c5..6332bf1e5e3c 100644
--- a/dev-python/asttokens/Manifest
+++ b/dev-python/asttokens/Manifest
@@ -1 +1,2 @@
DIST asttokens-2.0.5.gh.tar.gz 46876 BLAKE2B 8a8da138888de0a4096b10eccc483c9540710acde0da188ed3fb3845f96b862fe2eec393c69ca62e7b313bfa0e2f0d673d828e9d1ff6dbbf5b641fe8122a548d SHA512 3e710ca9703e67643bb9c0a4db4e5c1656e6d5c904a1262a9ddb962beff06e4e8bd9815bcd2509b48974a97a565d8479a4369583c166a65b6d16c19fd926e93f
+DIST asttokens-2.0.7.gh.tar.gz 50675 BLAKE2B 75fbeb61b0f3ebba27cb3ea94d45cdb5810bb7b3b9cf1cdacc8e48fa800207af0e9ff4c162742944f30ca5253331f0f55aba21b6186d8a747e8e25f7b350baaa SHA512 eafa47f1e0683df2fc4f93a1f798b845f2d10b63f33eea689333df32e6ffc2b5e693298d912e82974ef4c65d3472aece3cbd0ecd05fa565eb0f94a45915f6905
diff --git a/dev-python/asttokens/asttokens-2.0.7.ebuild b/dev-python/asttokens/asttokens-2.0.7.ebuild
new file mode 100644
index 000000000000..839fb416705f
--- /dev/null
+++ b/dev-python/asttokens/asttokens-2.0.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Annotate Python AST trees with source text and token information"
+HOMEPAGE="
+ https://github.com/gristlabs/asttokens/
+ https://pypi.org/project/asttokens/
+"
+SRC_URI="
+ https://github.com/gristlabs/asttokens/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/astroid[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # test suite itself broken with new astroid versions, upstream less care
+ # https://github.com/gristlabs/asttokens/issues/79
+ tests/test_astroid.py
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}