summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-06 09:09:07 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-06 09:12:56 +0200
commitea1b081df6319f705b5b3ff0a2e60b65ec7e2ddb (patch)
treec7b5268a0ca84e211df4df0544122c9c84fc020b /dev-python/asttokens
parentdev-python/regex: Bump to 2021.7.6 (diff)
downloadgentoo-ea1b081df6319f705b5b3ff0a2e60b65ec7e2ddb.tar.gz
gentoo-ea1b081df6319f705b5b3ff0a2e60b65ec7e2ddb.tar.bz2
gentoo-ea1b081df6319f705b5b3ff0a2e60b65ec7e2ddb.zip
dev-python/asttokens: Port to py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asttokens')
-rw-r--r--dev-python/asttokens/asttokens-2.0.5.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-python/asttokens/asttokens-2.0.5.ebuild b/dev-python/asttokens/asttokens-2.0.5.ebuild
index cf7fc5d2a259..393339cec50b 100644
--- a/dev-python/asttokens/asttokens-2.0.5.ebuild
+++ b/dev-python/asttokens/asttokens-2.0.5.ebuild
@@ -1,9 +1,9 @@
# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Annotate Python AST trees with source text and token information"
@@ -29,3 +29,12 @@ BDEPEND="
distutils_enable_tests pytest
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == python3.8 ]] && deselect+=(
+ tests/test_astroid.py::TestAstroid::test_slices
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}