summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-04-19 22:22:57 -0700
committerZac Medico <zmedico@gentoo.org>2017-04-20 02:20:07 -0700
commitfa47822a43566361d1b9475e605ee24abcb5780e (patch)
treece6317fc10a7a650afc6733eae958b37862af32a /dev-python/async_timeout/async_timeout-1.2.0.ebuild
parentdev-python/pytest-aiohttp: Add python3_6 to PYTHON_COMPAT (diff)
downloadgentoo-fa47822a43566361d1b9475e605ee24abcb5780e.tar.gz
gentoo-fa47822a43566361d1b9475e605ee24abcb5780e.tar.bz2
gentoo-fa47822a43566361d1b9475e605ee24abcb5780e.zip
dev-python/async_timeout: version bump to 1.2.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/async_timeout/async_timeout-1.2.0.ebuild')
-rw-r--r--dev-python/async_timeout/async_timeout-1.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/async_timeout/async_timeout-1.2.0.ebuild b/dev-python/async_timeout/async_timeout-1.2.0.ebuild
new file mode 100644
index 000000000000..6785e3411e4c
--- /dev/null
+++ b/dev-python/async_timeout/async_timeout-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_P=${PN/_/-}-${PV}
+DESCRIPTION="Timeout context manager for asyncio programs"
+HOMEPAGE="https://github.com/aio-libs/async_timeout/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest-aiohttp[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test || die
+}