summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/atom
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/atom')
-rw-r--r--dev-python/atom/Manifest1
-rw-r--r--dev-python/atom/atom-0.3.10.ebuild50
-rw-r--r--dev-python/atom/metadata.xml9
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/atom/Manifest b/dev-python/atom/Manifest
new file mode 100644
index 000000000000..732ae5ac3c15
--- /dev/null
+++ b/dev-python/atom/Manifest
@@ -0,0 +1 @@
+DIST atom-0.3.10.zip 102102 SHA256 461ffb57ff9448242b66e08d367f9c65bfd9bf04215591e7e9580f289139debf SHA512 ae22747f96e42b9cc4f7c92ddb7d7b8af647e17b917481cd267d4162bd9260b906a019a73de2ca6e3c72a9430dacd535001da7dcb809c1c3dc18c7297be14b76 WHIRLPOOL 23a39d1dddb6c42850925244a8d6da1f589690e7c73416773e954f9ee74665e75c9686f5517af93711a226f828364b483497a98bbf054e4c97f75178ff77adce
diff --git a/dev-python/atom/atom-0.3.10.ebuild b/dev-python/atom/atom-0.3.10.ebuild
new file mode 100644
index 000000000000..2faba765d26a
--- /dev/null
+++ b/dev-python/atom/atom-0.3.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Memory efficient Python objects"
+HOMEPAGE="https://github.com/nucleic/atom"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="Clear-BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Required to avoid file collisions at install
+ sed -e "s:find_packages():find_packages(exclude=['tests']):" -i setup.py || die
+
+ # Reset from use of local paths
+ if use test; then
+ sed -e 's:from .catom:from catom:g' -i ${PN}/*.py || die
+ fi
+
+ append-flags -fno-strict-aliasing
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}"/lib:"${BUILD_DIR}"/lib/${PN} \
+ nosetests || die "Tests failed"
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ # Change the state back to original ready for installing
+ sed -e 's:from catom:from .catom:g' -i ${PN}/*.py
+ popd > /dev/null
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/atom/metadata.xml b/dev-python/atom/metadata.xml
new file mode 100644
index 000000000000..3485f522ab47
--- /dev/null
+++ b/dev-python/atom/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">atom</remote-id>
+ <remote-id type="github">nucleic/atom</remote-id>
+ </upstream>
+</pkgmetadata>