summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-02 22:01:42 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-02 22:05:22 +0300
commit8f639b214fa524fead41a53cd26285d319f0c987 (patch)
treea48c5041283e0e34089257f3ae24796ba74eb18f /dev-python/authheaders
parentdev-python/publicsuffix: mark ALLARCHES (diff)
downloadgentoo-8f639b214fa524fead41a53cd26285d319f0c987.tar.gz
gentoo-8f639b214fa524fead41a53cd26285d319f0c987.tar.bz2
gentoo-8f639b214fa524fead41a53cd26285d319f0c987.zip
dev-python/authheaders: enable py3.10, enable tests
Closes: https://bugs.gentoo.org/797778 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/authheaders')
-rw-r--r--dev-python/authheaders/authheaders-0.13.0.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-python/authheaders/authheaders-0.13.0.ebuild b/dev-python/authheaders/authheaders-0.13.0.ebuild
index 90a48e486795..a16e7617ac81 100644
--- a/dev-python/authheaders/authheaders-0.13.0.ebuild
+++ b/dev-python/authheaders/authheaders-0.13.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A library wrapping email authentication header verification and generation."
@@ -13,12 +13,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
- dev-python/dkimpy[${PYTHON_USEDEP}]
+RDEPEND="
>=dev-python/authres-1.0.1[${PYTHON_USEDEP}]
+ dev-python/dkimpy[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
>=dev-python/publicsuffix-2.20190205[${PYTHON_USEDEP}]
- dev-python/dnspython[${PYTHON_USEDEP}]"
-BDEPEND=""
+"
+
+distutils_enable_tests pytest