summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-09-20 13:00:52 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-09-20 13:02:43 -0700
commit112dc07dbcaa96a1a9019d5cd05109d3247fe5af (patch)
tree1e8820b1ef85d2cc231488cd9298f9ee63802f62 /dev-python/autobahn/autobahn-17.9.1.ebuild
parentdev-python/txtorcon: New pkg, new dep of net-misc/crossbar-17.9.1 (diff)
downloadgentoo-112dc07dbcaa96a1a9019d5cd05109d3247fe5af.tar.gz
gentoo-112dc07dbcaa96a1a9019d5cd05109d3247fe5af.tar.bz2
gentoo-112dc07dbcaa96a1a9019d5cd05109d3247fe5af.zip
dev-python/autobahn: Add 17.9.1 for matching net-mic/crossbar version
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/autobahn/autobahn-17.9.1.ebuild')
-rw-r--r--dev-python/autobahn/autobahn-17.9.1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/autobahn/autobahn-17.9.1.ebuild b/dev-python/autobahn/autobahn-17.9.1.ebuild
new file mode 100644
index 000000000000..d2b4a4e6bfc1
--- /dev/null
+++ b/dev-python/autobahn/autobahn-17.9.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+
+DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/autobahn http://autobahn.ws/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm"
+IUSE="crypt test"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/trollius-2.0[${PYTHON_USEDEP}]' 'python2_7')
+ $(python_gen_cond_dep '>=dev-python/futures-3.0.4[${PYTHON_USEDEP}]' 'python2_7')
+ >=dev-python/cbor-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lz4-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/py-ubjson-0.8.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/snappy-0.5[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.6.0-r2[${PYTHON_USEDEP}]
+ >=dev-python/txaio-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/u-msgpack-2.1[${PYTHON_USEDEP}]
+ >=dev-python/wsaccel-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-3.6[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/pyopenssl-16.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/service_identity-16.0.0
+ )
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_test() {
+ #esetup.py test
+ cd "${BUILD_DIR}"/lib || die
+ py.test -v || die
+}
+
+pkg_postinst() {
+ python_foreach_impl twisted-regen-cache || die
+}
+
+pkg_postrm() {
+ python_foreach_impl twisted-regen-cache || die
+}