summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-08-30 17:22:42 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-08-30 18:17:40 -0700
commitaa3fefd662e61d7864522ab26a043739e59d31b2 (patch)
tree47a0d74fa4588040f5b23a06bdf7bace079e0be0 /dev-python/autobahn
parentdev-python/txaio: Version bump, dep of dev-python/autobahn-0.16.0 (diff)
downloadgentoo-aa3fefd662e61d7864522ab26a043739e59d31b2.tar.gz
gentoo-aa3fefd662e61d7864522ab26a043739e59d31b2.tar.bz2
gentoo-aa3fefd662e61d7864522ab26a043739e59d31b2.zip
dev-python/autobahn: Version bump, updated dep of dev-util/buildbot
This version of autobahn is required by buildbot-0.9 for >=dev-python/twisted-16.3.0. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/autobahn')
-rw-r--r--dev-python/autobahn/Manifest1
-rw-r--r--dev-python/autobahn/autobahn-0.16.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/autobahn/Manifest b/dev-python/autobahn/Manifest
index 7c1f30f70c6e..f09cfc6c7da1 100644
--- a/dev-python/autobahn/Manifest
+++ b/dev-python/autobahn/Manifest
@@ -1,4 +1,5 @@
DIST autobahn-0.10.4.tar.gz 148147 SHA256 3dd7a7793cead942cb0c06bef5a9f69e64edc174e47fb822702eafd41085933d SHA512 1eb43df9b0c986f1788c6463875765266cfc562155399c326b4e9bf447119fbfc967dcc53f8f8844700d21ebf37df6c596ead8c105918af5c6a8ec09585ce797 WHIRLPOOL b5be6d7f6348dc627fcbd2c60699cbd60e3e14e6494f787275d3890c30bca5804783b7a010faab5d19d19097ac90ddfdfdb1a3aaf6d37e4daef943916bf5422f
DIST autobahn-0.11.0.tar.gz 149680 SHA256 e7aea216e2a3bb41a4fec235399ece8bfbc0be4ef9567e1ed6927db7fa35f851 SHA512 9f53e2ef7637ddf9aec263fa2db8977c5b7a0d8a1bea6b21c030660d5d17e343cab5f84ebda8b0f97d55e1e4a77a0313805294a3a1487fce004c10a4cddfdc86 WHIRLPOOL f5ade4fc98a14585a8ee9a3e4141a6739668d402ff8c4fd42854062c01de33492093752e08a000f708bef232ce30039b51e0c53553f779da898ef526c861315f
DIST autobahn-0.12.1.tar.gz 163311 SHA256 664223879e159c88221f42d8d1ac6b8c4268d8b9316d8ab69a02761c5744cd79 SHA512 2d944ce6849017f75542b5f33cd2c4a7321c5a70ce01b24480fb17aa34c3a7dec826073261af1133e1611233dbe958e5c7d2a10b1586f6b7e5b32ce4f4e7db06 WHIRLPOOL 2d1d78ae0f468e80a7ffe44dc8f1891082adb97319d3cedad575f74ebafa3318a1b0ed1f9cd4187dc097d9a8c2cf2b0ca761c39511a6bbd490e8d30bcbb7d933
+DIST autobahn-0.16.0.tar.gz 185053 SHA256 a1dcb4315a0914da56ec484659816de72dfad229be4ac19fa61bbc0111ada884 SHA512 8873202a33c7b68577e89cc91503b8002aa19638836ff39ef99022e3b0ddcfb613154ddf0c373bf315eeb8b6c36f31afc20eb0164c47caa087b2a1b28449d3a8 WHIRLPOOL b5f5f80c1d88b3b031fab0837f0d191d4d71e21798aeec6ae1ee718bad0e21cb403a1b2ecb199615b4c8351522be8d4882781fd02de95e422203cee14f1c01ef
DIST autobahn-0.9.4-2.zip 175894 SHA256 5bb64191cfdd1cbdd90d8e359b389ef62c0acdffd2f68d16ec01fa0a287262f0 SHA512 7e0d4246b8b1c552b25c2ae36f1923ed9931e3d3ca684039a422773fecd92ca04734a0b24394a9bbc787f245c72b5552522351a7c1c8e500128e7c46c740a3d5 WHIRLPOOL aa0f06b82acbebb97ca2e3c424429ada7169dca5b39237ce082a17440ec9701a307e9fc7f162f957023cfc4c067f8e8b82b9923cb056ffcab7b3e64a61a4aae8
diff --git a/dev-python/autobahn/autobahn-0.16.0.ebuild b/dev-python/autobahn/autobahn-0.16.0.ebuild
new file mode 100644
index 000000000000..97947177795f
--- /dev/null
+++ b/dev-python/autobahn/autobahn-0.16.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1 versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+
+DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/autobahn http://autobahn.ws/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE="crypt test"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/trollius-2.0[${PYTHON_USEDEP}]' 'python2_7')
+ $(python_gen_cond_dep '>=dev-python/futures-3.0.4[${PYTHON_USEDEP}]' 'python2_7')
+ $(python_gen_cond_dep '>=dev-python/asyncio-3.4.3[${PYTHON_USEDEP}]' 'python3_3')
+ >=dev-python/cbor-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lz4-0.7.0[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
+ )
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/snappy-0.5[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/twisted-core-12.1[$(python_gen_usedep 'python2*')]
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ )
+ >=dev-python/txaio-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/u-msgpack-2.1[${PYTHON_USEDEP}]
+ >=dev-python/py-ubjson-0.8.4[${PYTHON_USEDEP}]
+ >=dev-python/wsaccel-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-3.6[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_test() {
+ esetup.py test
+}