summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-27 14:45:04 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-27 14:50:13 -0800
commitd77d2d0183c01f91ebbade3bae3adc673da99240 (patch)
tree2e099002c9142c9029fa73423c3a7c1586502c67 /dev-python/automat/automat-0.8.0.ebuild
parentdev-python/m2r-0.2.1: bump, add py38 and pypy3 (diff)
downloadgentoo-d77d2d0183c01f91ebbade3bae3adc673da99240.tar.gz
gentoo-d77d2d0183c01f91ebbade3bae3adc673da99240.tar.bz2
gentoo-d77d2d0183c01f91ebbade3bae3adc673da99240.zip
dev-python/automat-0.8.0: bump, add py38 and pypy3
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/automat/automat-0.8.0.ebuild')
-rw-r--r--dev-python/automat/automat-0.8.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/automat/automat-0.8.0.ebuild b/dev-python/automat/automat-0.8.0.ebuild
new file mode 100644
index 000000000000..075a0b131e2d
--- /dev/null
+++ b/dev-python/automat/automat-0.8.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="A${PN:1}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Self-service finite-state machines for the programmer on the go"
+HOMEPAGE="https://github.com/glyph/automat https://pypi.org/project/Automat/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-python/m2r[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/automat-0.8.0-no-setup-py-m2r-import.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use test ; then
+ # Remove since this is upstream benchmarking tests
+ rm -r benchmark || die "FAILED to remove benchmark tests"
+ fi
+
+ # avoid a setuptools_scm dependency
+ sed -r -i "s:use_scm_version=True:version='${PV}': ;
+ s:[\"']setuptools[_-]scm[\"'](,|)::" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc docs/examples/*.py
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo "For additional visualization functionality install these optional dependencies"
+ einfo " >=dev-python/twisted-16.1.1"
+ einfo " media-gfx/graphviz[python]"
+}