summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-05-27 16:39:29 +0200
committerDavid Seifert <soap@gentoo.org>2017-05-27 17:35:58 +0200
commitf713da99cead4085d1275329f49397206a48336d (patch)
treeb26e24b7c8062f5595244d1d61e44fca43166cd7 /dev-python/autopep8
parentnet-firewall/shorewall: Bump to v5.1.4.1 (diff)
downloadgentoo-f713da99cead4085d1275329f49397206a48336d.tar.gz
gentoo-f713da99cead4085d1275329f49397206a48336d.tar.bz2
gentoo-f713da99cead4085d1275329f49397206a48336d.zip
dev-python/autopep8: Version bump to 1.3.1
* Masked one unit test due to it failing on Gentoo Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-1.3.1.ebuild40
-rw-r--r--dev-python/autopep8/files/autopep8-1.3.1-test-line-length.patch28
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index b132a5864520..5e239cfa0cbb 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,2 +1,3 @@
DIST autopep8-1.0.4.tar.gz 121476 SHA256 58883a80d501f6f5d97859f100414c6b6f6131fcfc08bd88364c2ecb37a55153 SHA512 53e902dcdd654b9d67d9a31a2343503b754bec78630a7fd8d229843c53eb27d11c32fd6a4829714ac4d7cbee59b055d12e60453ae4ee01cb6131bf9c5045426f WHIRLPOOL 44748dfce6202e1e82c468862e4505500c939ee88eb474392767e606c537a66736f2788c0b6573db37b7c207f3f4608b2a6ecb0fb231bb8c3c090040d17f0642
DIST autopep8-1.2.4.tar.gz 105273 SHA256 38e31e266e29808e8a65a307778ed8e402e1f0d87472009420d6d18146cdeaa2 SHA512 f56c143d94521487628b225d9a0464ee5c8ca69aaea0c5e43c84f1dd920a0274508c6831da429e716829c38bc7c357842bb6403b8b61c04b464240e3573e05d6 WHIRLPOOL f551f8e2cb8b71664c2e47f7458c9923b70b420c044f980d67172b17f7ea9aa328141f9af648eedb400379dfb5a6ab804671fb1f942f8cca8a3ad851a5e9b3d2
+DIST autopep8-1.3.1.tar.gz 107541 SHA256 405eaa5199c74a0570125916e6af44d39343c1fcaaafee117fc329a3f86048c4 SHA512 f20de070b27520a9de56477b7d7b0ea2d3924b882687a43acb4cdbd25a727cfa48e15be4511be1706755e66164164766b405be3230edaecc8563e835e866a030 WHIRLPOOL a5579a23ab9112918c037ab9c10395c9841db919538f7dddb21ae15b8135f6cbc6cbff1403daaaedb95a97b3e6dfc841baa4c73186ebf05a393e276d164b7464
diff --git a/dev-python/autopep8/autopep8-1.3.1.ebuild b/dev-python/autopep8/autopep8-1.3.1.ebuild
new file mode 100644
index 000000000000..fbabaae44076
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.python.org/pypi/autopep8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.3.1-test-line-length.patch )
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/autopep8/files/autopep8-1.3.1-test-line-length.patch b/dev-python/autopep8/files/autopep8-1.3.1-test-line-length.patch
new file mode 100644
index 000000000000..5644a8a8a720
--- /dev/null
+++ b/dev-python/autopep8/files/autopep8-1.3.1-test-line-length.patch
@@ -0,0 +1,28 @@
+Fails with the following message:
+
+======================================================================
+FAIL: test_local_pycodestyle_config_line_length (test.test_autopep8.ConfigurationTests)
+----------------------------------------------------------------------
+Traceback (most recent call last):
+ File "/var/tmp/portage/dev-python/autopep8-1.3.1/work/autopep8-1.3.1/test/test_autopep8.py", line 4724, in test_local_pycodestyle_config_line_length
+ self.assertEqual(args.max_line_length, 40)
+AssertionError: 79 != 40
+
+----------------------------------------------------------------------
+
+--- a/test/test_autopep8.py
++++ b/test/test_autopep8.py
+@@ -4715,13 +4715,6 @@
+ self.assertEqual(args.global_config, 'False')
+ self.assertEqual(args.indent_size, 2)
+
+- def test_local_pycodestyle_config_line_length(self):
+- args = autopep8.parse_args(
+- [os.path.join(FAKE_PYCODESTYLE_CONFIGURATION, 'foo.py'),
+- '--global-config={0}'.format(os.devnull)],
+- apply_config=True)
+- self.assertEqual(args.max_line_length, 40)
+-
+ def test_config_false_with_local_autocomplete(self):
+ args = autopep8.parse_args(
+ [os.path.join(FAKE_CONFIGURATION, 'foo.py'),